Page MenuHomePhabricator

rc.local is executed too early
Closed, ResolvedPublic

Description

Hello!

According to the VyOS Wiki and the file itself, the content of vyatta-postconfig-bootup.script should be applied after the VyOS configuration is fully applied. As this is not the case anymore, many modifications via this file are not possible/working because they are applied too early. You can find an example in T209, despite the fact that the iptables chain in this example does not exist. It would be great if rc.local and therefore vyatta-postconfig-bootup.script would be executed after the configuration is fully applied, so that custom modifications can be used again.

Details

Difficulty level
Unknown (require assessment)
Version
-
Why the issue appeared?
Will be filled on close

Event Timeline

rcit created this task.Nov 24 2018, 1:05 PM
rcit created this object in space S1 VyOS Public.
hagbard claimed this task.Nov 29 2018, 12:09 AM
hagbard added a subscriber: hagbard.

It's triggered by systemd, so it will happen before the config is fully loaded. It might be better to move that into the cli config and execute with prio 999, that way it will be definitely the last script running.

hagbard triaged this task as Normal priority.Nov 29 2018, 12:10 AM
hagbard moved this task from Need Triage to Backlog on the VyOS 1.2 Crux board.
hagbard lowered the priority of this task from Normal to Low.Nov 29 2018, 8:25 PM
pasik added a subscriber: pasik.Mar 12 2019, 6:08 PM

@rcit Is that still a relevant issue?

rcit added a comment.Sep 16 2019, 3:43 PM

@hagbard I don't know if this is somehow relevant regarding VyOS 1.3, but i have tested it with VyOS 1.2.3-epa1 just today and it works perfectly.

hagbard closed this task as Resolved.Sep 16 2019, 6:08 PM

@rcit Lot's of development underway and since I wasn't able to reproduce it anymoe, I thought I ask, Feel free to reopen if the issue re-occurs.

c-po moved this task from Need Triage to Finished on the VyOS 1.3 Equuleus board.Sun, Oct 13, 3:07 PM