Page MenuHomePhabricator

mmc_block, sdhci, and sdhci_acpi modules for kernel
Closed, ResolvedPublicFEATURE REQUEST

Description

Multiple single board computers come with emmc storage, currently the vyos kernel image is lacking the proper support (in the form of the following kernel modules)

mmc_block
sdhci
sdhci_acpi

https://forum.vyos.io/t/1-2-0-rc10-no-mmc-block-module-available-for-kernel/3067

Details

Difficulty level
Easy (less than an hour)
Version
-
Why the issue appeared?
Will be filled on close

Event Timeline

trystan renamed this task from mmc_block, sdhci, and sdhci_api modules for kernel to mmc_block, sdhci, and sdhci_acpi modules for kernel.Dec 12 2018, 10:13 AM
trystan created this task.
trystan updated the task description. (Show Details)
c-po changed the task status from Open to In progress.Dec 12 2018, 7:45 PM
c-po claimed this task.
c-po added a comment.Dec 12 2018, 7:51 PM
  • CONFIG_MMC_BLOCK already enabled
  • CONFIG_MMC_SDHCI_ACPI has been enabled
c-po closed this task as Resolved.Dec 12 2018, 8:03 PM
c-po edited projects, added VyOS 1.2 Crux ( VyOS 1.2.0-EPA); removed VyOS 1.2 Crux.
c-po changed Difficulty level from Unknown (require assessment) to Easy (less than an hour).
c-po added a comment.Dec 13 2018, 11:02 AM

Please retest wirh latest rolling release

I've had a chance to retest with 1.2.0-rc11 and everything works as intended. Thank you!