Page MenuHomePhabricator

Not able to set static IPv6 routes
Closed, ResolvedPublicBUG

Description

When trying to set a static route i always fail:

vyos@<hostname># set protocols static route6 ::/0 blackhole distance 10

  Set failed

[edit]

This is not limited to default routes.

Details

Difficulty level
Unknown (require assessment)
Version
v1.2.0-rc11
Why the issue appeared?
Will be filled on close

can reproduce ob EPA3:

vyos@fw-1# set protocols static route6 ::/0 blackhole distance 10
[edit]
vyos@fw-1# commit
[edit]
vyos@fw-1# exit
vyos@fw-1:~$ show ipv6 route
Codes: K - kernel route, C - connected, S - static, R - RIPng,

O - OSPFv3, I - IS-IS, B - BGP, N - NHRP, T - Table,
v - VNC, V - VNC-Direct, A - Babel, D - SHARP, F - PBR,
f - OpenFabric,
> - selected route, * - FIB route

S>* ::/0 [10/0] unreachable (blackhole), 00:00:44
C>* 2001:400::/24 is directly connected, eth0, 3d05h52m
C>* 2001:470:1f0a:1323::/64 is directly connected, tun0, 3d05h52m
C>* 2001:470:9d91:2::/64 is directly connected, eth0.2, 3d05h52m
C>* 2001:470:9d91:3::/64 is directly connected, eth0.3, 3d05h52m
C>* 2001:470:9d91:4::/64 is directly connected, eth0.4, 3d05h52m
C>* 2001:470:9d91:5::/64 is directly connected, eth0.5, 3d05h52m
C>* 2001:470:9d91:6::/64 is directly connected, eth0.6, 3d05h52m
C>* 2a01:XXXX:2::/64 is directly connected, eth2, 3d05h52m
C * fe80::/64 is directly connected, tun0, 3d05h52m
C * fe80::/64 is directly connected, eth0.4, 3d05h52m
C * fe80::/64 is directly connected, eth0.5, 3d05h52m
C * fe80::/64 is directly connected, eth0.6, 3d05h52m
C * fe80::/64 is directly connected, eth0.2, 3d05h52m
C * fe80::/64 is directly connected, eth0.3, 3d05h52m
C * fe80::/64 is directly connected, eth2, 3d05h52m
C * fe80::/64 is directly connected, eth1, 3d05h52m
C>* fe80::/64 is directly connected, eth0, 3d05h52m

syncer closed this task as Wontfix.Jan 27 2019, 12:47 AM
syncer triaged this task as Normal priority.
syncer edited projects, added Invalid; removed VyOS 1.2 Crux.
syncer claimed this task.
syncer added a subscriber: syncer.

Can´t reproduce

dmbaturin changed the task status from Wontfix to Resolved.Jan 27 2019, 12:49 AM
dmbaturin added a subscriber: dmbaturin.

Works for me in the latest build.

vyos@vyos-test-2# set protocols static route6 ::/0 blackhole distance 10
[edit]
vyos@vyos-test-2# commit
[edit]
vyos@vyos-test-2# run show ipv6 route ::/0
Routing entry for ::/0
  Known via "static", distance 10, metric 0, best
  Last update 00:00:10 ago
  * unreachable (blackhole)

Confirmed working again (using rolling from 2019-01-29). Thank you for verification.