Page MenuHomeVyOS Platform

Can't login to the router after upgrade vyos from 1.1.8 to 1.2.0-epa3
Closed, InvalidPublicBUG

Description

I've tried to login using user 'vyos' (with password auth) and another user (with password and ssh-key access). I've tried to login using ssh and console - nothing works. Of course, every access method listed below works before this upgrade.

Details

Difficulty level
Unknown (require assessment)
Version
1.2.0-epa3
Why the issue appeared?
Will be filled on close

Event Timeline

Harliff created this task.EditedJan 24 2019, 11:04 PM

Resetting password right now... Done, access granted!
It was lucky that I have access to console at this time...

Harliff added a comment.EditedJan 24 2019, 11:12 PM

Hmm... The config contains only one user - for which one I've reseted password. The user 'vyos' is completely missing!

Just upgraded another router from 1.1.8 to 1.2.0-epa3 without this problem.

syncer closed this task as Invalid.Jan 27 2019, 4:16 AM
syncer edited projects, added Invalid; removed VyOS 1.2 Crux (VyOS 1.2.0-EPA3).
syncer added a subscriber: syncer.

Can't reproduce

srgjp added a subscriber: srgjp.Jun 23 2020, 6:15 PM

Same Problem here: After upgrading from 1.3-rolling-202005030117 to 1.3-rolling-202006230700 no login possible. After resetting password for admin user through password recovery login works. Rest of configuration was copied as should.

srgjp added a comment.Jun 23 2020, 6:23 PM

Just reproduced same issue on second system. Source VMware vSphere Host.

srgjp added a comment.Jun 24 2020, 6:01 AM

No problem occured after updating another machine from version VyOS 1.2-rolling-201910102056 to 1.3-rolling-202006230700. Login succeeded after reboot immediately.