Webproxy config scripts make incorrect assumptions about the config path
Closed, ResolvedPublic

Description

When you try to activate the web proxy on the Nightly from 8/13 you get the following error.

Couldn't open /etc/squid/squidGuard.conf - No such file or directory at /opt/vyatta/share/perl5/Vyatta/Webproxy.pm line 409.

From what it looks like the path for squidguard.conf has changed from /etc/squid/squidGuard.conf to /etc/squidguard/squidguard.conf. I was able to temporarily fix this with a simlink

Details

Difficulty level
Easy (less than an hour)
Version
1.2.0-beta1
thadrumr created this task.Aug 14 2016, 1:04 PM
dmbaturin added a project: VyOS 1.1.x (1.1.8).
dmbaturin renamed this task from Webproxy bug to Webproxy config scripts make incorrect assumptions about the config path.Aug 14 2016, 1:25 PM
dmbaturin triaged this task as High priority.
dmbaturin set Version to 1.2.0-beta1.
syncer edited subscribers, added: VyOS 1.2.x; removed: VyOS 1.1.x (1.1.8).
UnicronNL added a subscriber: dmbaturin.

update squidguard package in 1.2

The issue was the folder change, not the conf file name. The conf file is still squidGuard.conf
Pull request: https://github.com/vyos/vyatta-webproxy/pull/6

@syncer This can be closed as it was a duplicate of T92.

syncer closed this task as Resolved.May 27 2018, 9:12 AM
syncer edited projects, added VyOS 1.2.x (VyOS 1.2.0-rc1); removed VyOS 1.2.x.
syncer moved this task from Needs Triage to Finished on the VyOS 1.2.x (VyOS 1.2.0-rc1) board.