Page MenuHomePhabricator

Set the serial console speed to 115200 by default
Closed, ResolvedPublicBUG

Description

Most, if not all, new boards have the serial port speed set to 115200 by default. The default speed of 9600 is just a headache for their users, especially at the installation stage, since the config of a livecd cannot be altered.

We need input from users of older boards that do not support 115200 to see how common they still are though.

The plan is to make the change in current, and address the needs of users of older boards, should they arise.

Details

Difficulty level
Easy (less than an hour)
Version
1.2.0
Why the issue appeared?
Will be filled on close

Event Timeline

dmbaturin created this task.Apr 7 2019, 6:47 PM
pasik added a subscriber: pasik.Apr 10 2019, 2:43 PM
dmbaturin changed the edit policy from "Custom Policy" to "Subscribers".
jestabro updated the task description. (Show Details)Apr 16 2019, 12:02 PM

To complete this, the corresponding changes need to be made in vyatta-cfg-system; these are straightforward and will be pushed to current. However, there is another mechanism whereby the console speed is explicitly being set to 9600: the vyatta-config-migrate script, called during system initialization, is invoking migrate/system/3-to-4, which sets the console speed; this will require some discussion as to how to best address.

Note that the mentioned annoyance of migrate/system/3-to-4 setting the serial console speed should be mooted by 'T805 Drop config compatibility with Vyatta Core older than 6.5'.

jestabro closed this task as Resolved.May 22 2019, 3:10 PM

Testing confirms that the default console speed is set to 115200 when the old migration scripts are removed, as they will be by

T805 Drop config compatibility with Vyatta Core older than 6.5
resp.,
T1398 Remove vyatta-config-migrate package

c-po moved this task from Need Triage to Finished on the VyOS 1.3 Equuleus board.Jun 1 2019, 7:45 AM
c-po added a subscriber: c-po.EditedJun 16 2019, 12:12 AM

Using an APU4 board this does not work. ISOLINUX has no serial console set, and the kernel command line seems to have no serial interface either.

The whole ISO can't be installed on those boards using a 115200 serial interface

c-po reopened this task as In progress.Jun 16 2019, 12:13 AM
c-po added a comment.Jun 16 2019, 10:06 AM

In addition, latest rolling release when beeted from ISO show this behavior in /opt/vyatta/etc/config/config.boot

c-po added a comment.EditedJun 16 2019, 11:01 AM

@jestabro the root cause looks like this line: https://github.com/vyos/vyatta-config-migrate/blob/current/migrate/system/3-to-4#L33-L37

Config migrator is invoked when booting up a LiveCD which cause the serial port to be changed again to 9600. A quick test by removing this call was successful. Can you please check how to fix the issue?

It can be verified by booting an ISO and just checking the running configuration, which reports 9600 at this time.

c-po moved this task from Finished to In Progress on the VyOS 1.3 Equuleus board.Jun 16 2019, 11:01 AM

Thanks @c-po --- to clarify, I had pointed out this issue with https://github.com/vyos/vyatta-config-migrate/blob/current/migrate/system/3-to-4 earlier in the task, which will be a non-issue once T805: Drop config compatibility with Vyatta Core older than 6.5 is completed. However, since we are not quite ready for that, I will find a current solution.

I had initially not planned to drop the explicit set_value for console speed in migrate/system/3-to-4, as this was legacy for the system@4 component definition; however, (1) the file is soon to be removed when we drop config compatibility pre-6.5, (2) it is now redundant/wrong in the /opt/vyatta/etc/config/config.boot, as pointed out by c-po above. I will remove the add_console call from vyatta-config-migrate/migrate/system/3-to-4.

jestabro closed this task as Resolved.Jun 19 2019, 2:00 PM
jestabro moved this task from In Progress to Finished on the VyOS 1.3 Equuleus board.