Page MenuHomePhabricator

vxlan remote-port
Closed, ResolvedPublicBUG

Description

Hello,

if

interface vxlan <vxlanN> remote-port

is not set, the commit creates a problem that the interface can no longer be edited. in the status the interface must delte commit and recreate with remote-port.

vyos@vyos# compare
[edit interfaces]
+vxlan vxlan123 {
+    remote 192.168.188.2
+    vni 123
+}
[edit]
vyos@vyos# commit
[ interfaces vxlan vxlan123 ]
vxlan: destination port not specified
Will use Linux kernel default (non-standard value)
Use 'dstport 4789' to get the IANA assigned value
Use 'dstport 0' to get default and quiet this message

vyos@vyos# set interfaces vxlan vxlan123 remote-port 4789
[edit]
vyos@vyos# commit
[ interfaces vxlan vxlan123 remote-port 4789 ]
Changing remote port requires delete/create this vxlan interface

[[interfaces vxlan vxlan123]] failed
Commit failed
[edit]
vyos@vyos#

maybe it is better to don't commit the change when the remote-port is not set?

Details

Difficulty level
Easy (less than an hour)
Version
1.2.1
Why the issue appeared?
Implementation mistake

Event Timeline

rob created this task.May 19 2019, 7:47 PM
c-po claimed this task.May 20 2019, 10:31 AM
c-po changed Why the issue appeared? from Will be filled on close to Implementation mistake.
c-po added a comment.May 20 2019, 3:19 PM

We should not emit any warning at all - this was caused by a bug in the remote-port implementation.

c-po closed this task as Resolved.May 20 2019, 3:20 PM
c-po triaged this task as Normal priority.
c-po added a project: VyOS 1.3 Equuleus.
c-po moved this task from Need Triage to Finished on the VyOS 1.3 Equuleus board.
c-po moved this task from Need Triage to VyOS 1.2.2 on the VyOS 1.2 Crux board.
c-po edited projects, added VyOS 1.2 Crux (VyOS 1.2.2); removed VyOS 1.2 Crux.
c-po changed Difficulty level from Unknown (require assessment) to Easy (less than an hour).
c-po moved this task from Needs Triage to Finished on the VyOS 1.2 Crux (VyOS 1.2.2) board.
c-po added a comment.May 20 2019, 3:34 PM

@rob Fix will be in next rolling release

rob added a comment.May 21 2019, 7:04 PM

the commit success now in the latest rolling.

but now 8472/UDP is used. Who set this? The Kernel?
according to https://tools.ietf.org/html/rfc7348 the port 4789 should use.

c-po added a comment.EditedMay 21 2019, 8:55 PM

8472 is the default port used by the Kernel, and thus fully backwards compatible with older installations. 4789 is the IANA assigned value which you could configure using remote-port.

This behavior could be changed but I see no reason to do so as the port can be adjusted via CLI.

pasik added a subscriber: pasik.May 27 2019, 8:20 PM