Page MenuHomePhabricator

T1656 equuleus: buster: arm64/aarch64: ipaddrcheck does not complete testing
Closed, ResolvedPublicENHANCEMENT

Description

Interation tests fails when building ipaddrcheck on arm64/aarch64

Console log:
https://pastebin.com/b36itfSL

test-log:

===========================================
   ipaddrcheck 1.0: tests/test-suite.log
===========================================

# TOTAL: 2
# PASS:  1
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: integration_tests.sh
==========================

test #1 "../src/ipaddrcheck --is-valid 192.0.2.1" failed:
	program terminated with code 2 instead of 0
test #2 "../src/ipaddrcheck --is-valid 192.0.2.0" failed:
	program terminated with code 2 instead of 0
test #3 "../src/ipaddrcheck --is-valid 0.0.0.0" failed:
	program terminated with code 2 instead of 0
test #4 "../src/ipaddrcheck --is-valid 0.0.0.1" failed:
	program terminated with code 2 instead of 0
test #5 "../src/ipaddrcheck --is-valid 255.255.255.255" failed:
	program terminated with code 2 instead of 0
test #6 "../src/ipaddrcheck --is-valid 192.0.2.1/0" failed:
	program terminated with code 2 instead of 0
test #7 "../src/ipaddrcheck --is-valid 192.0.2.1/32" failed:
	program terminated with code 2 instead of 0
test #8 "../src/ipaddrcheck --is-valid 192.0.2.1/24" failed:
	program terminated with code 2 instead of 0
test #9 "../src/ipaddrcheck --is-valid 192.0.2.0/26" failed:
	program terminated with code 2 instead of 0
test #10 "../src/ipaddrcheck --is-valid 2001:0db8:0000:0000:0000:ff00:0042:8329" failed:
	program terminated with code 2 instead of 0
test #11 "../src/ipaddrcheck --is-valid 2001:db8:0:0:0:ff00:42:8329" failed:
	program terminated with code 2 instead of 0
test #12 "../src/ipaddrcheck --is-valid 2001:db8::1" failed:
	program terminated with code 2 instead of 0
test #13 "../src/ipaddrcheck --is-valid ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff" failed:
	program terminated with code 2 instead of 0
test #14 "../src/ipaddrcheck --is-valid 0000::" failed:
	program terminated with code 2 instead of 0
test #15 "../src/ipaddrcheck --is-valid ::1" failed:
	program terminated with code 2 instead of 0
test #16 "../src/ipaddrcheck --is-valid ::" failed:
	program terminated with code 2 instead of 0
test #17 "../src/ipaddrcheck --is-valid 2001:db8::/0" failed:
	program terminated with code 2 instead of 0
test #18 "../src/ipaddrcheck --is-valid 2001:db8::/128" failed:
	program terminated with code 2 instead of 0
test #19 "../src/ipaddrcheck --is-valid 2001:db8::/56" failed:
	program terminated with code 2 instead of 0
test #20 "../src/ipaddrcheck --is-valid ::/0" failed:
	program terminated with code 2 instead of 0
test #21 "../src/ipaddrcheck --is-valid 192.0.2.666" failed:
	program terminated with code 2 instead of 1
test #22 "../src/ipaddrcheck --is-valid 500.0.2.1" failed:
	program terminated with code 2 instead of 1
test #23 "../src/ipaddrcheck --is-valid 192.0.2.1/33" failed:
	program terminated with code 2 instead of 1
test #24 "../src/ipaddrcheck --is-valid 192.0.2.666/32" failed:
	program terminated with code 2 instead of 1
test #25 "../src/ipaddrcheck --is-valid gggg::ffff" failed:
	program terminated with code 2 instead of 1
test #26 "../src/ipaddrcheck --is-valid 2001:db8::bad::f00d" failed:
	program terminated with code 2 instead of 1
test #27 "../src/ipaddrcheck --is-valid 2001:db8::/129" failed:
	program terminated with code 2 instead of 1
test #28 "../src/ipaddrcheck --is-valid garbage" failed:
	program terminated with code 2 instead of 1
test #29 "../src/ipaddrcheck --is-any-cidr 192.0.2.1/0" failed:
	program terminated with code 2 instead of 0
test #30 "../src/ipaddrcheck --is-any-cidr 192.0.2.1/32" failed:
	program terminated with code 2 instead of 0
test #31 "../src/ipaddrcheck --is-any-cidr 192.0.2.1/24" failed:
	program terminated with code 2 instead of 0
test #32 "../src/ipaddrcheck --is-any-cidr 192.0.2.0/26" failed:
	program terminated with code 2 instead of 0
test #33 "../src/ipaddrcheck --is-any-cidr 2001:db8::/0" failed:
	program terminated with code 2 instead of 0
test #34 "../src/ipaddrcheck --is-any-cidr 2001:db8::/128" failed:
	program terminated with code 2 instead of 0
test #35 "../src/ipaddrcheck --is-any-cidr 2001:db8::/56" failed:
	program terminated with code 2 instead of 0
test #36 "../src/ipaddrcheck --is-any-cidr ::/0" failed:
	program terminated with code 2 instead of 0
test #37 "../src/ipaddrcheck --is-any-cidr 192.0.2.1" failed:
	program terminated with code 2 instead of 1
test #38 "../src/ipaddrcheck --is-any-cidr 192.0.2.1/33" failed:
	program terminated with code 2 instead of 1
test #39 "../src/ipaddrcheck --is-any-cidr 192.0.2.666/32" failed:
	program terminated with code 2 instead of 1
test #40 "../src/ipaddrcheck --is-any-cidr 2001:0db8:0000:0000:0000:ff00:0042:8329" failed:
	program terminated with code 2 instead of 1
test #41 "../src/ipaddrcheck --is-any-cidr 2001:db8::/129" failed:
	program terminated with code 2 instead of 1
test #42 "../src/ipaddrcheck --is-any-cidr garbage" failed:
	program terminated with code 2 instead of 1
test #43 "../src/ipaddrcheck --is-any-single 192.0.2.1" failed:
	program terminated with code 2 instead of 0
test #44 "../src/ipaddrcheck --is-any-single 192.0.2.0" failed:
	program terminated with code 2 instead of 0
test #45 "../src/ipaddrcheck --is-any-single 0.0.0.0" failed:
	program terminated with code 2 instead of 0
test #46 "../src/ipaddrcheck --is-any-single 0.0.0.1" failed:
	program terminated with code 2 instead of 0
test #47 "../src/ipaddrcheck --is-any-single 255.255.255.255" failed:
	program terminated with code 2 instead of 0
test #48 "../src/ipaddrcheck --is-any-single 2001:0db8:0000:0000:0000:ff00:0042:8329" failed:
	program terminated with code 2 instead of 0
test #49 "../src/ipaddrcheck --is-any-single 2001:db8:0:0:0:ff00:42:8329" failed:
	program terminated with code 2 instead of 0
test #50 "../src/ipaddrcheck --is-any-single 2001:db8::1" failed:
	program terminated with code 2 instead of 0
test #51 "../src/ipaddrcheck --is-any-single ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff" failed:
	program terminated with code 2 instead of 0
test #52 "../src/ipaddrcheck --is-any-single 0000::" failed:
	program terminated with code 2 instead of 0
test #53 "../src/ipaddrcheck --is-any-single ::1" failed:
	program terminated with code 2 instead of 0
test #54 "../src/ipaddrcheck --is-any-single ::" failed:
	program terminated with code 2 instead of 0
test #55 "../src/ipaddrcheck --is-any-single 192.0.2.666" failed:
	program terminated with code 2 instead of 1
test #56 "../src/ipaddrcheck --is-any-single 500.0.2.1" failed:
	program terminated with code 2 instead of 1
test #57 "../src/ipaddrcheck --is-any-single gggg::ffff" failed:
	program terminated with code 2 instead of 1
test #58 "../src/ipaddrcheck --is-any-single 2001:db8::bad::f00d" failed:
	program terminated with code 2 instead of 1
test #59 "../src/ipaddrcheck --is-any-single garbage" failed:
	program terminated with code 2 instead of 1
test #60 "../src/ipaddrcheck --is-ipv4 192.0.2.1" failed:
	program terminated with code 2 instead of 0
test #61 "../src/ipaddrcheck --is-ipv4 192.0.2.0" failed:
	program terminated with code 2 instead of 0
test #62 "../src/ipaddrcheck --is-ipv4 0.0.0.0" failed:
	program terminated with code 2 instead of 0
test #63 "../src/ipaddrcheck --is-ipv4 0.0.0.1" failed:
	program terminated with code 2 instead of 0
test #64 "../src/ipaddrcheck --is-ipv4 255.255.255.255" failed:
	program terminated with code 2 instead of 0
test #65 "../src/ipaddrcheck --is-ipv4 192.0.2.1/0" failed:
	program terminated with code 2 instead of 0
test #66 "../src/ipaddrcheck --is-ipv4 192.0.2.1/32" failed:
	program terminated with code 2 instead of 0
test #67 "../src/ipaddrcheck --is-ipv4 192.0.2.1/24" failed:
	program terminated with code 2 instead of 0
test #68 "../src/ipaddrcheck --is-ipv4 192.0.2.0/26" failed:
	program terminated with code 2 instead of 0
test #69 "../src/ipaddrcheck --is-ipv4 192.0.2.666" failed:
	program terminated with code 2 instead of 1
test #70 "../src/ipaddrcheck --is-ipv4 500.0.2.1" failed:
	program terminated with code 2 instead of 1
test #71 "../src/ipaddrcheck --is-ipv4 192.0.2.1/33" failed:
	program terminated with code 2 instead of 1
test #72 "../src/ipaddrcheck --is-ipv4 192.0.2.666/32" failed:
	program terminated with code 2 instead of 1
test #73 "../src/ipaddrcheck --is-ipv4 2001:0db8:0000:0000:0000:ff00:0042:8329" failed:
	program terminated with code 2 instead of 1
test #74 "../src/ipaddrcheck --is-ipv4 2001:db8::/0" failed:
	program terminated with code 2 instead of 1
test #75 "../src/ipaddrcheck --is-ipv4 garbage" failed:
	program terminated with code 2 instead of 1
test #76 "../src/ipaddrcheck --is-ipv4-cidr 192.0.2.1/0" failed:
	program terminated with code 2 instead of 0
test #77 "../src/ipaddrcheck --is-ipv4-cidr 192.0.2.1/32" failed:
	program terminated with code 2 instead of 0
test #78 "../src/ipaddrcheck --is-ipv4-cidr 192.0.2.1/24" failed:
	program terminated with code 2 instead of 0
test #79 "../src/ipaddrcheck --is-ipv4-cidr 192.0.2.0/26" failed:
	program terminated with code 2 instead of 0
test #80 "../src/ipaddrcheck --is-ipv4-cidr 192.0.2.1" failed:
	program terminated with code 2 instead of 1
test #81 "../src/ipaddrcheck --is-ipv4-cidr 192.0.2.1/33" failed:
	program terminated with code 2 instead of 1
test #82 "../src/ipaddrcheck --is-ipv4-cidr 192.0.2.666/32" failed:
	program terminated with code 2 instead of 1
test #83 "../src/ipaddrcheck --is-ipv4-cidr 2001:0db8:0000:0000:0000:ff00:0042:8329" failed:
	program terminated with code 2 instead of 1
test #84 "../src/ipaddrcheck --is-ipv4-cidr 2001:db8::/0" failed:
	program terminated with code 2 instead of 1
test #85 "../src/ipaddrcheck --is-ipv4-cidr garbage" failed:
	program terminated with code 2 instead of 1
test #86 "../src/ipaddrcheck --is-ipv4-single 192.0.2.1" failed:
	program terminated with code 2 instead of 0
test #87 "../src/ipaddrcheck --is-ipv4-single 192.0.2.0" failed:
	program terminated with code 2 instead of 0
test #88 "../src/ipaddrcheck --is-ipv4-single 0.0.0.0" failed:
	program terminated with code 2 instead of 0
test #89 "../src/ipaddrcheck --is-ipv4-single 0.0.0.1" failed:
	program terminated with code 2 instead of 0
test #90 "../src/ipaddrcheck --is-ipv4-single 255.255.255.255" failed:
	program terminated with code 2 instead of 0
test #91 "../src/ipaddrcheck --is-ipv4-single 192.0.2.666" failed:
	program terminated with code 2 instead of 1
test #92 "../src/ipaddrcheck --is-ipv4-single 500.0.2.1" failed:
	program terminated with code 2 instead of 1
test #93 "../src/ipaddrcheck --is-ipv4-single 2001:0db8:0000:0000:0000:ff00:0042:8329" failed:
	program terminated with code 2 instead of 1
test #94 "../src/ipaddrcheck --is-ipv4-single 2001:db8::/0" failed:
	program terminated with code 2 instead of 1
test #95 "../src/ipaddrcheck --is-ipv4-single garbage" failed:
	program terminated with code 2 instead of 1
95 of 95 ipaddrcheck_integration tests failed in 3.208s.
FAIL integration_tests.sh (exit status: 95)

Details

Difficulty level
Unknown (require assessment)
Version
-
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Perfectly compatible

Event Timeline

runar triaged this task as Normal priority.Sep 15 2019, 7:22 AM
runar created this task.
runar added a comment.Sep 15 2019, 7:26 AM

The same build procedure is tested fine on x86_64 and armhf without this issue

runar added a comment.Sep 15 2019, 5:53 PM

the error in the test-log is just the errorcode, but the real error message is a memory allocation error:

vyos_bld@dd27213bf7b5:/vyos/ipaddrcheck/src$ ./ipaddrcheck
Error: could not allocate memory!
hagbard added a subscriber: hagbard.EditedWed, Sep 25, 9:35 PM

I've tested it and can't reproduce. There are a few issues in the debian files and autoreconf, but other than that everything seems to work just fine.

./ipaddrcheck --is-any-cidr 10.0.0.0/24 && echo $?
0
file ipaddrcheck
ipaddrcheck: ELF 64-bit LSB pie executable, ARM aarch64, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-aarch64.so.1, for GNU/Linux 3.7.0, BuildID[sha1]=4a10776d0f8d7f43e141b597d228c673b5ad0f23, with debug_info, not stripped

 lscpu 
Architecture:        aarch64
Byte Order:          Little Endian
CPU(s):              1
On-line CPU(s) list: 0
Thread(s) per core:  1
Core(s) per socket:  1
Socket(s):           1
NUMA node(s):        1
Vendor ID:           ARM
Model:               0
Model name:          Cortex-A57
Stepping:            r1p0
BogoMIPS:            125.00
NUMA node0 CPU(s):   0
Flags:               fp asimd evtstrm aes pmull sha1 sha2 crc32 cpuid
hagbard claimed this task.Thu, Sep 26, 4:03 PM
hagbard closed this task as Resolved.Wed, Oct 9, 3:19 PM
c-po moved this task from Need Triage to Finished on the VyOS 1.3 Equuleus board.Sun, Oct 13, 3:02 PM