Page MenuHomePhabricator

VyOS 1.2 Rolling 201910110117 DHCP Server Configuration Fails
Closed, ResolvedPublic

Description

If you do a clean install of vyos "vyos-1.2-rolling-201910110117-amd64.iso" as of right now that's the latest rolling release, DHCP configuration will fail to save.

Commands Executed:

set service dhcp-server shared-network-name 'LAN' authoritative
set service dhcp-server shared-network-name 'LAN' subnet '172.16.0.0/24' range 0 start '172.16.0.150'
set service dhcp-server shared-network-name 'LAN' subnet '172.16.0.0/24' range 0 stop '172.16.0.254'
set service dhcp-server shared-network-name 'LAN' subnet '172.16.0.0/24' default-router '172.16.0.1'
set service dhcp-server shared-network-name 'LAN' subnet '172.16.0.0/24' dns-server '172.16.1.1'
set service dhcp-server shared-network-name 'LAN' subnet '172.16.0.0/24' domain-name 'internal-net'
set service dhcp-server shared-network-name 'LAN' subnet '172.16.0.0/24' lease 86400

INTERFACES:
eth0 = WAN = 172.16.1.52/24
eth1 = LAN = 172.16.0.1/24

Screenshot of error on commit:

Details

Difficulty level
Unknown (require assessment)
Version
1.2-rolling
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Perfectly compatible

Event Timeline

brian.ward triaged this task as High priority.Oct 11 2019, 4:57 PM
brian.ward created this task.
brian.ward created this object in space S1 VyOS Public.
hagbard claimed this task.Oct 11 2019, 5:20 PM

Can't reproduce it, it does work without any issues. I copied and executed your config and did a commit.

@brian.ward Can you please check that /config is mounted?

hagbard changed Version from 1.2 to 1.2-rolling.

Absolutely, I was going to paste a screen shot of the running config.
I’m eating lunch let me respond when I get back if that’s alright.

If it helps, I should have also said this is running in VMWare ESXi 6.7.
The vm OS is Debian Linux 8.

Sent from a mobile device, please excuse any brevity and typos.

c-po added a subscriber: c-po.Oct 11 2019, 5:38 PM

@brian.ward I just tried to reproduce this with a clean VyOS installation and it works as expected.

hagbard lowered the priority of this task from High to Normal.Oct 11 2019, 5:53 PM

@brian.ward Please show the output of df-h at your earliest convenience.

Sure enough, /config is not mounted.
Not sure how the configuration was being saved.

Here's what the show command looks like with the DHCP config (unsaved).

Output of df -h:

I apologize for wasting your time.

It's been about a year since I last used VyOS and I sincerely apologize.
I already know what I did wrong.

brian.ward closed this task as Resolved.Oct 11 2019, 6:53 PM
brian.ward lowered the priority of this task from Normal to Low.
c-po added a comment.Oct 11 2019, 7:23 PM

@brian.ward no problem. Could you please tell us what was your problem so we could probably reference this in the future for other people?

running from the live-cd I think.

Yes I was running from a live image exactly as hagbard mentioned.

Sent from a mobile device, please excuse any brevity and typos.

syncer moved this task from Need Triage to Finished on the VyOS 1.2 Crux board.Sat, Nov 16, 11:45 PM