Page MenuHomePhabricator

error in generated /etc/hosts file
Closed, ResolvedPublicBUG

Description

From forum: https://forum.vyos.io/t/dhcp-hostnames-of-clients-not-resolving-after-update-v1-2-3-1-2-rolling/4393

There seems to be a bug in v1.2.3: the first entry in the hosts file is missing a carriage return and then it fails to resolve that hostname. the subsequent ones will work though.

admin@vyos:~$ cat /etc/hosts

### Autogenerated by VyOS ###
### Do not edit, your changes will get overwritten ###

# Local host
127.0.0.1       localhost
127.0.1.1       vyos.lan vyos

# The following lines are desirable for IPv6 capable hosts
::1             localhost ip6-localhost ip6-loopback
fe00::0         ip6-localnet
ff00::0         ip6-mcastprefix
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters

# From DHCP and "system static host-mapping"192.168.1.150	 macosmini.lan	 #on-dhcp-event 00:00:0F:11:11:11
192.168.1.150	 macmini.lan	 #on-dhcp-event 00:00:0F:11:11:11

Details

Difficulty level
Easy (less than an hour)
Version
1.2.3
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Perfectly compatible

Event Timeline

c-po created this task.Nov 18 2019, 3:17 PM
pasik added a subscriber: pasik.Nov 18 2019, 8:01 PM
syncer assigned this task to hagbard.Nov 23 2019, 12:04 PM
syncer triaged this task as Low priority.
syncer edited projects, added VyOS 1.3 Equuleus; removed VyOS 1.2 Crux.
hagbard closed this task as Resolved.Thu, Jan 9, 5:21 PM

Has been fixed already.