Page MenuHomeVyOS Platform

DHCPv6 client does not start
Closed, ResolvedPublicBUG

Description

Bug description:
When the interface is set to both dhcp and dhcpv6:

admin@vyos# set interfaces ethernet eth0 address dhcp
[edit]
admin@vyos# set interfaces ethernet eth0 address dhcpv6
[edit]
admin@vyos# commit
[ interfaces ethernet eth0 ]
Traceback (most recent call last):
  File "/usr/libexec/vyos/conf_mode/interfaces-ethernet.py", line 449, in <module>
    apply(c)
  File "/usr/libexec/vyos/conf_mode/interfaces-ethernet.py", line 401, in apply
    e.add_addr(addr)
  File "/usr/lib/python3/dist-packages/vyos/ifconfig.py", line 450, in add_addr
    if addr != 'dhcp' and is_ipv4(addr):
  File "/usr/lib/python3/dist-packages/vyos/validate.py", line 32, in is_ipv4
    if ipaddress.ip_address(addr.split(r'/')[0]).version == 4:
  File "/usr/lib/python3.4/ipaddress.py", line 54, in ip_address
    address)
ValueError: 'dhcpv6' does not appear to be an IPv4 or IPv6 address

[[interfaces ethernet eth0]] failed
Commit failed
[edit]

When del this interface address:

admin@vyos# delete interfaces ethernet eth0 address
[edit]
admin@vyos# commit
[edit]
admin@vyos# save
Saving configuration to '/config/config.boot'...
Done
[edit]
admin@vyos# run show int
Codes: S - State, L - Link, u - Up, D - Down, A - Admin Down
Interface        IP Address                        S/L  Description
---------        ----------                        ---  -----------
eth0             192.168.1.87/24                   u/u
eth1             192.168.0.1/24                    u/u
eth2             -                                 u/u
lo               127.0.0.1/8                       u/u
                 ::1/128
[edit]
admin@vyos# show interfaces ethernet eth0
 hw-id 00:0c:29:8c:4b:82
[edit]

System version is:

admin@vyos:~$ show version
Version:          VyOS 1.2-rolling-201912050217
Built by:         autobuild@vyos.net
Built on:         Thu 05 Dec 2019 02:17 UTC
Build UUID:       89a5ca9a-c2f5-4ba0-95f8-177d7bdfa8ff
Build Commit ID:  21841422ba1337

Architecture:     x86_64
Boot via:         livecd
System type:      VMware guest

Hardware vendor:  VMware, Inc.
Hardware model:   VMware Virtual Platform
Hardware S/N:     VMware-56 4d 8a 02 d3 70 f0 57-49 1b 31 06 fa 8c 4b 82
Hardware UUID:    028a4d56-70d3-57f0-491b-3106fa8c4b82

Copyright:        VyOS maintainers and contributors

Details

Difficulty level
Unknown (require assessment)
Version
1.2-rolling-201912060217
Why the issue appeared?
Implementation mistake
Is it a breaking change?
Unspecified (possibly destroys the router)
Issue type
Bug (incorrect behavior)

Event Timeline

xzjt renamed this task from A bug caused by a DHCPv6 client to A bug caused by DHCPv6 client.Dec 5 2019, 12:07 PM
c-po renamed this task from A bug caused by DHCPv6 client to DHCPv6 client does not start.Dec 6 2019, 6:34 PM
c-po closed this task as Resolved.
c-po triaged this task as High priority.
c-po edited projects, added VyOS 1.3 Equuleus; removed VyOS 1.2 Crux (VyOS 1.2.4).
c-po changed Version from VyOS 1.2.x to 1.2-rolling-201912060217.
c-po changed Why the issue appeared? from Will be filled on close to Implementation mistake.
erkin set Issue type to Bug (incorrect behavior).Aug 31 2021, 6:10 PM