Page MenuHomePhabricator

OpenVPN bug
Closed, InvalidPublicBUG

Description

I just setup a OpenVPN road-warrior VPN on crux.

When I was configuring VyOS I got the following errors setting TLS:

<<<BEGIN>>>
set interfaces openvpn vtun0 tls ca-cert-file /config/auth/opl/pki/ca.crt

WARNING: File '/config/auth/opl/pki/ca.crt' not found

Configuration path: [interfaces openvpn vtun0 tls ca-cert-file /config/auth/opl/pki/ca.crt] already exists
<<<END>>>

I received this error for entries in the tls node. However, I was able to commit and the OpenVPN server is working.

I do not know if this is a know issue or if this is just me.

Details

Difficulty level
Unknown (require assessment)
Version
1.2.3
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Perfectly compatible

Event Timeline

max1e6 created this task.Dec 16 2019, 1:04 PM
pasik added a subscriber: pasik.Dec 19 2019, 8:34 PM
syncer assigned this task to hagbard.Jan 1 2020, 1:53 PM
syncer triaged this task as Normal priority.
syncer edited projects, added VyOS 1.3 Equuleus; removed VyOS 1.2 Crux.
hagbard changed the task status from Open to In progress.Jan 6 2020, 2:19 AM

Hi @max1e6 , can you please share the relevant openvpn config, so I can try to reproduce the issue? Thx.

max1e6 added a comment.Jan 6 2020, 1:29 PM

Hi,

I just did a build of Crux 1.2.4. The issue that appeared in 1.2.3 did not occur in 1.2.4.

max1e6 added a comment.Jan 6 2020, 1:30 PM

This was tested on a different VyOS install, so I will test again and confirm.

hagbard changed the task status from In progress to On hold.Jan 6 2020, 7:49 PM

Sure thing, let me know the result.

@max1e6 Did you have a chance to test?

@max1e6 Did you have a chance to test? Otherwise I assume the issue isn't present anymore.

hagbard closed this task as Invalid.Sun, Jan 26, 1:42 AM
c-po moved this task from Need Triage to Finished on the VyOS 1.3 Equuleus board.Sun, Feb 9, 2:15 PM