Page MenuHomeVyOS Platform

pppoe-server: Add possibility set multiple service-name
Closed, ResolvedPublicFEATURE REQUEST

Description

Feature request from https://forum.vyos.io/t/multiple-service-name-on-pppoe/4805
Propose add multiple service-names, in config it has syntax

[pppoe]
service-name=sn1,sn2,sn3

For VyOS CLI better use

set service pppoe-server service-name sn1
set service pppoe-server service-name sn2
set service pppoe-server service-name sn3

Details

Difficulty level
Easy (less than an hour)
Version
-
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Unspecified (possibly destroys the router)

Event Timeline

Dmitry created this task.Feb 23 2020, 5:50 PM
hagbard claimed this task.Feb 23 2020, 6:47 PM
hagbard triaged this task as Low priority.
hagbard changed Difficulty level from Unknown (require assessment) to Easy (less than an hour).
pasik added a subscriber: pasik.Feb 23 2020, 9:32 PM
hagbard changed the task status from Open to In progress.Feb 23 2020, 11:48 PM
hagbard changed the task status from In progress to Needs testing.EditedFeb 24 2020, 12:11 AM

https://github.com/vyos/vyos-1x/commit/d9fa3fb7d7613cd5d6297115da0dc63462d4cf69
@Dmitry next rolling will have it enabled, let me know if it works for you as intended.

@hagbard thanks, works as expected. I think this might be backport candidate to 1.2.X

hagbard changed the task status from Needs testing to Backport candidate.Feb 24 2020, 6:53 PM
hagbard closed this task as Resolved.Jul 27 2020, 3:28 PM