Page MenuHomeVyOS Platform

"show interfaces" does not return VTI
Closed, ResolvedPublicBUG

Description

Since 1.3-rolling-202006061515 the command show interfaces do not show anymore the vti interfaces
I've only ethernet and vti so at the moment I can't check the other interfaces type

Before

vyos@vyos:~$ show interfaces 
Codes: S - State, L - Link, u - Up, D - Down, A - Admin Down
Interface        IP Address                        S/L  Description
---------        ----------                        ---  -----------
eth0             -                                 u/u  
eth0.20          172.16.1.21/26                    u/u    
eth0.30          10.39.11.101/24                   u/u   
                 10.39.11.100/24
lo               127.0.0.1/8                       u/u  
                 10.1.200.93/32
                 ::1/128
vti1             10.1.80.22/30                     u/u  
vti2             10.1.80.42/30                     u/u

After:

vyos@vyos:~$ show interfaces 
Codes: S - State, L - Link, u - Up, D - Down, A - Admin Down
Interface        IP Address                        S/L  Description
---------        ----------                        ---  -----------
eth0             -                                 u/u  
eth0.20          172.16.1.21/26                    u/u    
eth0.30          10.39.11.101/24                   u/u   
                 10.39.11.100/24
lo               127.0.0.1/8                       u/u  
                 10.1.200.93/32
                 ::1/128

Also show interfaces vti detail do not return any value

Details

Difficulty level
Unknown (require assessment)
Version
1.3-rolling-202006061515
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Unspecified (possibly destroys the router)

Event Timeline

I suppose the problem is related to T2546 and the the op-mode: T2546: migrate show interfaces tunnel,input,pseudo-ethernet,… github commit

Sorry for the poor help

pasik added a subscriber: pasik.Jun 10 2020, 8:46 AM

hello Fabio, could you please show me how the vti interfaces are presented under Linux so I can fix the code. I thought I had properly ported the code from Perl to Python must I must have misunderstood something.

fabio.prina added a comment.EditedJun 10 2020, 1:14 PM

hello Thomas
What exactly do you need ?

The following 2 blocks are the VTI related part of ifconfig and ip addr ...

vti1:  flags=209<UP,POINTOPOINT,RUNNING,NOARP>  mtu 1500
        inet 10.1.80.22  netmask 255.255.255.252  destination 10.1.80.22
        tunnel   txqueuelen 1000  (IPIP Tunnel)
        RX packets 24863  bytes 1329228 (1.2 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 24869  bytes 1328944 (1.2 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vti2:  flags=209<UP,POINTOPOINT,RUNNING,NOARP>  mtu 1500
        inet 10.1.80.42  netmask 255.255.255.252  destination 10.1.80.42
        tunnel   txqueuelen 1000  (IPIP Tunnel)
        RX packets 24832  bytes 1327576 (1.2 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 24865  bytes 1328348 (1.2 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
5: ip_vti0@NONE: <NOARP> mtu 1480 qdisc noop state DOWN group default qlen 1000
    link/ipip 0.0.0.0 brd 0.0.0.0
6: vti1@NONE: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    link/ipip 172.16.1.21 peer XXX.XXX.XXX.XXX
    inet 10.1.80.22/30 scope global vti1
       valid_lft forever preferred_lft forever
7: vti2@NONE: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    link/ipip 172.16.1.21 peer YYY.YYY.YYY.YYY
    inet 10.1.80.42/30 scope global vti2
       valid_lft forever preferred_lft forever

XXX.XXX.XXX.XXX and YYY.YYY.YYY.YYY are the public IP address

The patch was merged and the issue should be resolved with the next ISO.

c-po changed the task status from Open to Needs testing.Jun 15 2020, 2:54 PM
c-po assigned this task to thomas-mangin.
c-po triaged this task as Normal priority.
c-po moved this task from Need Triage to In Progress on the VyOS 1.3 Equuleus board.

Thanks to all of you

thomas-mangin closed this task as Resolved.Jun 15 2020, 3:39 PM
c-po moved this task from In Progress to Finished on the VyOS 1.3 Equuleus board.Aug 4 2020, 6:05 AM