Page MenuHomeVyOS Platform

disabled vti interfaces still working
Closed, ResolvedPublic

Description

set interfaces vti vti026 disable
commit
show interfaces vti

Interface        IP Address                        S/L  Description
---------        ----------                        ---  -----------
vti026           172.30.10.26/31                   u/u

Details

Difficulty level
Unknown (require assessment)
Version
1.2.6-epa1
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Unspecified (possibly destroys the router)

Event Timeline

Harliff created this object in space S1 VyOS Public.
Harliff updated the task description. (Show Details)

Looks like it's a floating bug - I've just sucscessfuly disabled a vti interface on another router (running vyos 1.2.6-epa1).

Any suggestions how to debug this issue?

erkin changed the task status from Open to Needs testing.Wed, Jun 2, 8:39 AM

Waiting for T3595 to clear up before I can test this on rolling release.

I can't reproduce it in 1.2.7 and VyOS 1.3-beta-202105272051

LTS:

vyos@r2-lts:~$ show int vti 
Codes: S - State, L - Link, u - Up, D - Down, A - Admin Down
Interface        IP Address                        S/L  Description
---------        ----------                        ---  -----------
vti2             10.1.0.2/30                       A/D

1.3:

vyos@r4-1.3# set interfaces vti vti2 disable 
[edit]
vyos@r4-1.3# commit
[edit]
vyos@r4-1.3# exit
Warning: configuration changes have not been saved.
exit
vyos@r4-1.3:~$ show interfaces vti 
Codes: S - State, L - Link, u - Up, D - Down, A - Admin Down
Interface        IP Address                        S/L  Description
---------        ----------                        ---  -----------
vti2             10.1.0.1/30                       A/D

I can't reproduce it in 1.2.7

Just checked 1.2.7:

$ sudo sed -n 242p /opt/vyatta/sbin/vyatta-vti-config.pl

my $disabled = $vcIntf->existsOrig("vti $intfName disabled");

It should be "disable", not "disabled". The correct string should be:

my $disabled = $vcIntf->existsOrig("vti $intfName disable");

Currently (I'm still using couple of the 1.2.6 in production) I have to modify this file by hands after every reboot of a VyOS router.

Ok it already fixed in 1.3 T2916 and can be migrated to crux

c-po removed a project: VyOS 1.4 Sagitta.
c-po moved this task from Needs Triage to Finished on the VyOS 1.2 Crux (VyOS 1.2.8) board.
c-po moved this task from Need Triage to Finished on the VyOS 1.3 Equuleus board.