Page MenuHomeVyOS Platform

DHCP client on bond interfaces not working
Closed, InvalidPublicBUG

Description

vyos@R2# show interfaces bonding 
 bonding bond10 {
     address dhcp
     hash-policy layer3+4
     member {
         interface eth1
         interface eth2
     }
     mode 802.3ad
 }
Sep 14 18:10:54 R2 dhclient[2628]: DHCPDISCOVER on bond10 to 255.255.255.255 port 67 interval 8
Sep 14 18:10:54 R2 dhclient[2651]: Killed old client process
Sep 14 18:10:54 R2 dhclient[2651]: Killed old client process
Sep 14 18:10:55 R2 systemd[1]: dhclient@bond10.service: Succeeded.
Sep 14 18:10:55 R2 systemd[1]: dhclient@bond10.service: Service RestartSec=100ms expired, scheduling restart.
Sep 14 18:10:55 R2 systemd[1]: dhclient@bond10.service: Scheduled restart job, restart counter is at 2.
Sep 14 18:10:55 R2 systemd[1]: Stopped DHCP client on bond10.
Sep 14 18:10:55 R2 systemd[1]: Starting DHCP client on bond10...
Sep 14 18:10:55 R2 systemd[1]: Started DHCP client on bond10.
Sep 14 18:10:55 R2 dhclient-script-vyos[2709]: Current dhclient PID: 2708, Parent PID: 2707, IP version: -4, All dhclients for interface bond10: 2707 2708
Sep 14 18:10:55 R2 dhclient-script-vyos[2709]: Passing command to /usr/sbin/ip: "link set dev bond10 up"
Sep 14 18:10:55 R2 dhclient-script-vyos[2709]: No changes to apply via vyos-hostsd-client
Sep 14 18:10:55 R2 dhclient[2708]: DHCPDISCOVER on bond10 to 255.255.255.255 port 67 interval 7
Sep 14 18:10:55 R2 dhclient[2731]: Killed old client process
Sep 14 18:10:55 R2 dhclient[2731]: Killed old client process
Sep 14 18:10:56 R2 systemd[1]: dhclient@bond10.service: Succeeded.
Sep 14 18:10:57 R2 systemd[1]: dhclient@bond10.service: Service RestartSec=100ms expired, scheduling restart.
Sep 14 18:10:57 R2 systemd[1]: dhclient@bond10.service: Scheduled restart job, restart counter is at 3.
Sep 14 18:10:57 R2 systemd[1]: Stopped DHCP client on bond10.
Sep 14 18:10:57 R2 systemd[1]: Starting DHCP client on bond10...
Sep 14 18:10:57 R2 systemd[1]: Started DHCP client on bond10.
Sep 14 18:10:57 R2 dhclient-script-vyos[2734]: Current dhclient PID: 2733, Parent PID: 2732, IP version: -4, All dhclients for interface bond10: 2732 2733
Sep 14 18:10:57 R2 dhclient-script-vyos[2734]: Passing command to /usr/sbin/ip: "link set dev bond10 up"
Sep 14 18:10:57 R2 dhclient-script-vyos[2734]: No changes to apply via vyos-hostsd-client
Sep 14 18:10:57 R2 dhclient[2733]: DHCPDISCOVER on bond10 to 255.255.255.255 port 67 interval 3
Sep 14 18:10:57 R2 dhclient[2756]: Killed old client process
Sep 14 18:10:57 R2 dhclient[2756]: Killed old client process
Sep 14 18:10:58 R2 systemd[1]: dhclient@bond10.service: Succeeded.
Sep 14 18:10:58 R2 systemd[1]: dhclient@bond10.service: Service RestartSec=100ms expired, scheduling restart.
Sep 14 18:10:58 R2 systemd[1]: dhclient@bond10.service: Scheduled restart job, restart counter is at 4.
Sep 14 18:10:58 R2 systemd[1]: Stopped DHCP client on bond10.
Sep 14 18:10:58 R2 systemd[1]: Starting DHCP client on bond10...
Sep 14 18:10:58 R2 systemd[1]: Started DHCP client on bond10.
Sep 14 18:10:58 R2 dhclient-script-vyos[2759]: Current dhclient PID: 2758, Parent PID: 2757, IP version: -4, All dhclients for interface bond10: 2757 2758
Sep 14 18:10:58 R2 dhclient-script-vyos[2759]: Passing command to /usr/sbin/ip: "link set dev bond10 up"
Sep 14 18:10:58 R2 dhclient-script-vyos[2759]: No changes to apply via vyos-hostsd-client
Sep 14 18:10:58 R2 dhclient[2758]: DHCPDISCOVER on bond10 to 255.255.255.255 port 67 interval 6
Sep 14 18:10:58 R2 dhclient[2781]: Killed old client process
Sep 14 18:10:58 R2 dhclient[2781]: Killed old client process
Sep 14 18:10:59 R2 systemd[1]: dhclient@bond10.service: Succeeded.
Sep 14 18:11:00 R2 systemd[1]: dhclient@bond10.service: Service RestartSec=100ms expired, scheduling restart.
Sep 14 18:11:00 R2 systemd[1]: dhclient@bond10.service: Scheduled restart job, restart counter is at 5.
Sep 14 18:11:00 R2 systemd[1]: Stopped DHCP client on bond10.
Sep 14 18:11:00 R2 systemd[1]: dhclient@bond10.service: Start request repeated too quickly.
Sep 14 18:11:00 R2 systemd[1]: dhclient@bond10.service: Failed with result 'start-limit-hit'.
Sep 14 18:11:00 R2 systemd[1]: Failed to start DHCP client on bond10.

Details

Difficulty level
Unknown (require assessment)
Version
1.3-rolling-202009140541
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Unspecified (possibly destroys the router)

Event Timeline

c-po changed the task status from Open to Confirmed.Mon, Sep 14, 6:15 PM
c-po triaged this task as High priority.
c-po created this task.
pasik added a subscriber: pasik.Tue, Sep 15, 7:14 AM
Viacheslav added a subscriber: Viacheslav.EditedTue, Sep 15, 8:58 AM

I can't reproduce it

vyos@r1-roll:~$ show int
Codes: S - State, L - Link, u - Up, D - Down, A - Admin Down
Interface        IP Address                        S/L  Description
---------        ----------                        ---  -----------
bond0            -                                 u/u  
dum0             10.11.11.1/24                     u/u  
eth0             192.168.122.11/24                 u/u  
eth1             -                                 A/D  
eth2             -                                 u/u  
lo               127.0.0.1/8                       u/u  
                 ::1/128                                
vyos@r1-roll:~$ conf
[edit]
vyos@r1-roll# set interfaces bonding bond0 address dh
dhcp    dhcpv6  
[edit]
vyos@r1-roll# set interfaces bonding bond0 address dhcp
[edit]
vyos@r1-roll# commit
[edit]
vyos@r1-roll# run show int
Codes: S - State, L - Link, u - Up, D - Down, A - Admin Down
Interface        IP Address                        S/L  Description
---------        ----------                        ---  -----------
bond0            100.64.0.10/24                    u/u  
dum0             10.11.11.1/24                     u/u  
eth0             192.168.122.11/24                 u/u  
eth1             -                                 A/D  
eth2             -                                 u/u  
lo               127.0.0.1/8                       u/u  
                 ::1/128                                
[edit]
vyos@r1-roll#

Conf

vyos@r1-roll# run show conf com | match bond
set interfaces bonding bond0 address 'dhcp'
set interfaces bonding bond0 hash-policy 'layer3+4'
set interfaces bonding bond0 member interface 'eth1'
set interfaces bonding bond0 member interface 'eth2'
set interfaces bonding bond0 mode '802.3ad'
[edit]

Logs

Sep 15 08:55:27 r1-roll systemd[1]: Created slice system-dhclient.slice.
Sep 15 08:55:27 r1-roll systemd[1]: Starting DHCP client on bond0...
Sep 15 08:55:28 r1-roll systemd[1]: Started DHCP client on bond0.
Sep 15 08:55:28 r1-roll dhclient-script-vyos[2788]: Current dhclient PID: 2783, Parent PID: 2777, IP version: -4, All dhclients for interface bond0: 2777 2783
Sep 15 08:55:28 r1-roll dhclient-script-vyos[2788]: Passing command to /usr/sbin/ip: "link set dev bond0 up"
Sep 15 08:55:28 r1-roll dhclient-script-vyos[2788]: No changes to apply via vyos-hostsd-client
Sep 15 08:55:28 r1-roll dhclient[2783]: DHCPDISCOVER on bond0 to 255.255.255.255 port 67 interval 4
Sep 15 08:55:29 r1-roll dhclient[2783]: DHCPOFFER of 100.64.0.10 from 100.64.0.1
Sep 15 08:55:29 r1-roll dhclient[2783]: DHCPREQUEST for 100.64.0.10 on bond0 to 255.255.255.255 port 67
Sep 15 08:55:29 r1-roll dhclient[2783]: DHCPACK of 100.64.0.10 from 100.64.0.1
Sep 15 08:55:29 r1-roll dhclient-script-vyos[2862]: Current dhclient PID: 2783, Parent PID: 1, IP version: -4, All dhclients for interface bond0: 2783
Sep 15 08:55:29 r1-roll dhclient-script-vyos[2862]: Passing command to /usr/sbin/ip: "-4 addr add 100.64.0.10/255.255.255.0 broadcast 100.64.0.255 valid_lft 86400 preferred_lft 86400 dev bond0 label bond0"
Sep 15 08:55:29 r1-roll dhclient-script-vyos[2862]: FRR status: running
Sep 15 08:55:29 r1-roll dhclient-script-vyos[2862]: Checking if the route presented in kernel: default via 100.64.0.1 dev bond0
Sep 15 08:55:29 r1-roll dhclient-script-vyos[2862]: Converted vtysh command: "ip route 0.0.0.0/0 100.64.0.1 bond0 tag 210 210 "
Sep 15 08:55:29 r1-roll dhclient-script-vyos[2862]: Sending command to vtysh
Sep 15 08:55:29 r1-roll dhclient-script-vyos[2862]: No changes to apply via vyos-hostsd-client
Sep 15 08:55:29 r1-roll dhclient-script-vyos[2862]: No changes to apply via vyos-hostsd-client
Sep 15 08:55:29 r1-roll dhclient[2783]: bound to 100.64.0.10 -- renewal in 37756 seconds.
[edit]

Version

vyos@r1-roll# run show version 

Version:          VyOS 1.3-rolling-202009140541
Release Train:    equuleus

Built by:         autobuild@vyos.net
Built on:         Mon 14 Sep 2020 05:41 UTC
Build UUID:       af971124-c47b-40d8-8745-bb9de2de1a9d
Build Commit ID:  daf4f59001d4c0

Architecture:     x86_64
Boot via:         installed image
System type:      KVM guest

Hardware vendor:  QEMU
Hardware model:   Standard PC (Q35 + ICH9, 2009)
Hardware S/N:     Unknown
Hardware UUID:    Unknown

Copyright:        VyOS maintainers and contributors

@c-po do you use vrf?

I think it was a bug with virtio drivers and bonding.

c-po added a comment.Tue, Sep 15, 3:57 PM

Yeah - its a bug when used in EVE-ng - closing

c-po closed this task as Invalid.Tue, Sep 15, 3:57 PM