Page MenuHomeVyOS Platform

VyOS 1.2 (Beta) doesn't save OpenVpn interface in /config/config.boot file
Closed, ResolvedPublic

Description

I just tried using VyOS 1.2 (Beta) and it doesn't seem to save the openvpn interfaces in the /config/config.boot file when the "save" command is run inside the "configure" command.

It looks like "commit" actually does configure the openvpn interface and it shows when the "show" command is given.

It just doesn't save it with "save".

Am I doing something wrong/wierd or do other people see this issue as well?

Is this something easy to fix?

I tested with vyos-999.201703212237-amd64.iso file.

I think if this one thing worked I would be able to use the VyOS 1.2 (Beta) as-is.

To replicate:
Try creating a site-to-site openvpn interface and "commit" and then "save". It doesn't show up in the /config/config.boot file.

However, if you "show" the configuration it shows up there.

Details

Difficulty level
Easy (less than an hour)
Version
vyos-999.201703212237
Why the issue appeared?
Implementation mistake

Event Timeline

dsummers created this task.Mar 29 2017, 2:28 AM
JulesT added a subscriber: JulesT.Jul 3 2017, 2:38 PM

Hmmm. Can't reproduce this on v999.20170626 at least.

For example: Post configuration as part of 'show configuration':

interfaces {

ethernet eth0 {
    address dhcp
    hw-id 08:00:27:d1:23:b0
}
loopback lo {
}
openvpn vtun1 {
    local-address 10.255.1.1 {
    }
    local-host 10.75.0.167
    local-port 1195
    mode site-to-site
    persistent-tunnel
    protocol udp
    remote-address 10.255.1.2
    remote-port 1195
    shared-secret-key-file /config/auth/openvpn-1.key
}

And on a cat /config/config.boot:

interfaces {

ethernet eth0 {
    address dhcp
    duplex auto
    hw-id 08:00:27:d1:23:b0
    smp-affinity auto
    speed auto
}
loopback lo {
}
openvpn vtun1 {
    local-address 10.255.1.1 {
    }
    local-host 10.75.0.167
    local-port 1195
    mode site-to-site
    persistent-tunnel
    protocol udp
    remote-address 10.255.1.2
    remote-port 1195
    shared-secret-key-file /config/auth/openvpn-1.key
}

Is it possible this is resolved, but the bug report remains?

syncer reassigned this task from syncer to JulesT.Aug 1 2017, 3:14 AM
syncer triaged this task as Low priority.
syncer changed the edit policy from "Task Author" to "Custom Policy".
syncer set Version to vyos-999.201703212237.
syncer edited subscribers, added: Maintainers, Community, Active contributors; removed: JulesT.
syncer added subscribers: JulesT, syncer.

@JulesT assigning this to you,
we can close this is if not reproducible

JulesT closed this task as Resolved.Aug 28 2017, 4:07 PM

Yup. Definately not reproducible.

My guess is that it must have been fixed between vyos-999.201703212237 and when I first tried - v999.20170626.

So... I'm closing this one. If anybody sees anything like it, let me know, and I'll try to wade into it.

Agreed. I just re-tried it as of 2017-09-05 and it now saves the OpenVPN configuration file in the /config/config.boot file.

Thanks!