Page MenuHomeVyOS Platform

L2TPv3 interface: Enforced to shutdown but no command to enable interface permanently
Closed, ResolvedPublicBUG

Description

Hey guys,

I having an issue with current rolling 1.3 release. I would like to use L2TPv3 interfaces for ip tunnels between different routers. I can create those L2TPv3 interfaces. But then still stock in A/D because source code enforce admin state down.

I can only activate interface with an sudo ip link set {ifname} up. But when i commit any change of that interface or reboot router the interface is set to admin state down?

Following configuration creates an L2TPv3 interface which is enforced to shutdown.

l2tpv3 l2tpeth10 {
address 192.168.37.1/27
encapsulation ip
local-ip 192.0.2.1
peer-session-id 100
peer-tunnel-id 200
remote-ip 203.0.113.24
session-id 100
tunnel-id 200
}

Because code enforce admin state down.

python/vyos/ifconfig/l2tpv3.py:

# interface is always A/D down. It needs to be enabled explicitly
self.set_admin_state('down')

Which makes no sense because you cannot enable interface permanently. We should do that a better way around and use disable command to shutdown interface permanently.

I have created an pull request for this change.

Details

Difficulty level
Easy (less than an hour)
Version
1.3
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Perfectly compatible
Issue type
Improvement (missing useful functionality)

Event Timeline

Dmitry changed the task status from Open to Confirmed.Nov 11 2020, 3:41 PM
Dmitry closed this task as Resolved.EditedNov 13 2020, 7:14 AM
Dmitry claimed this task.
Dmitry added a subscriber: Dmitry.

Tested on 1.3-rolling-202011130217, all works as expected.
Thanks to @ernstjo

erkin set Issue type to Improvement (missing useful functionality).
erkin removed a subscriber: Active contributors.