Page MenuHomeVyOS Platform

Outside interface eth0 can't recieve DHCP address from ISP
Closed, WontfixPublic

Description

Using vyos beta build VyOS 999.201704252137 DHCP on eth0 which is my outside interface, works fine. When I try to use VyOS 999.201704302137, the outside interface eth0 can't pull an address from my ISP.

My suspicion is that this build is somehow forcing VyOS to use DHCPv6, which my ISP does not support. When I delete and set the dhcp on/off command on the outside interface using the 4/30 build I get warning about how DHCPv6 is not configured. I do not get such warnings with the 4/25 build.

Anyone have some advice/suggestions on this?

Details

Difficulty level
Easy (less than an hour)
Version
VyOS 999.201704302137
Why the issue appeared?
Will be filled on close

Event Timeline

JulesT added a subscriber: JulesT.Jul 3 2017, 2:26 PM

Can't reproduce this on (at least) 999.201706262137, at least on my local network getting DHCP for eth0.

Thanks for the info. I'll try the 06/25 build or newer. I haven't had time to troubleshoot this issue properly since I made the ticket. I also have a suspicion that there might be a driver issue where the NIC is not being supported but I haven't had a chance to test. I'll try the latest build and go from there.

syncer triaged this task as Low priority.Aug 1 2017, 3:00 AM
syncer changed the edit policy from "Task Author" to "Custom Policy".
syncer edited projects, added VyOS 1.2 Crux; removed VyOS 1.2 Crux (VyOS 1.2.0-rc1).
syncer edited subscribers, added: Community, Maintainers, Active contributors; removed: grumbles.
syncer closed this task as Wontfix.Nov 3 2017, 12:43 PM

Looks like fixed as no further reports provided

syncer edited projects, added Rejected; removed VyOS 1.2 Crux.Oct 15 2018, 6:30 AM