Page MenuHomeVyOS Platform

Interface becomes up at boot even when disabled
Closed, ResolvedPublicBUG

Description

I've got a VLAN interface set up (WAN in a HA setup) which is disabled on boot, and gets activated via transition script when it becomes master router via VRRP, and again gets disabled when it reutrns to backup/fault role.

The thing I noticed is, that even though the interface is disabled, it actually becomes up on boot (u/u in show interfaces) instead of down (A/D). If DHCP is enabled, the interface receives an IP on boot. Removing the DHCP address option doesn't help.

Confuiguration as follows:

$ show interfaces ethernet eth0 vif 1000 | strip-private
 address dhcp
 description WAN
 disable
 mac XX:XX:XX:XX:XX:00
$ run show interfaces ethernet eth0 vif 1000 | strip-private
[email protected]: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether XX:XX:XX:XX:XX:00 brd XX:XX:XX:XX:XX:ff
    inet6 fe80::xxxx:xxxx:fedc:8a00/64 scope link
       valid_lft forever preferred_lft forever
    Description: WAN

    RX:  bytes  packets  errors  dropped  overrun       mcast
             0        0       0        0        0           0
    TX:  bytes  packets  errors  dropped  carrier  collisions
             0        0       0        0        0           0

Details

Difficulty level
Unknown (require assessment)
Version
1.4-rolling-202102271630
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Unspecified (possibly destroys the router)

Event Timeline

Please retest using the latest ISO image, fix is in there

c-po changed the task status from Open to Needs testing.Mar 1 2021, 7:08 PM
c-po claimed this task.

Works great, interface remains disabled on boot, as configured.

Thanks.