Page MenuHomeVyOS Platform

getty forces --keep-baud in 1.2.x
Open, Requires assessmentPublicBUG

Description

After upgrading to 1.2.x, my IPMI serial consoles are broken because getty passes --keep-baud and the kernel command line does not start with the right bit rate.

In 1.1.8, the getty command was /sbin/getty -L ttyS1 115200 vt100. In 1.2.6, it is /sbin/agetty --keep-baud 115200 ttyS1 vt102. I verified that editing the systemd unit and removing --keep-baud makes getty work again.

It seems to me that if a user has manually configured a bit rate in set system console device blah speed, then --keep-baud should not be on the generated command line? It would also be nice if this console device would be configured in grub.cfg so that it got initialized correctly at boot time...

Details

Difficulty level
Unknown (require assessment)
Version
1.2.6-S1
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Unspecified (possibly destroys the router)

Event Timeline

This totally breaks remote console access for me on 1.2.6, FWIW, so I consider it a fairly serious bug.