Page MenuHomePhabricator

VyOS OSPF doesn't send LS update on flapping interface
Closed, ResolvedPublicBUG

Description

This is my topology, and the flapping interface is ether2 on 10411p-cpe001.

If ether2 goes down and up, the ABR routers o6/r1-10411 first loses and then receives the route from 10411p-cpe001 ether2 interface (172.16.31.0/24)
The problem is that they're not sending out the update again out in area 0.

If I once again disable and enable ether2 on cpe, the route is updated into area 0 and area 172.24.31.240 ABR. However, this isn't true 100% of the times, but seems to be related to how long the interface is down/disabled.

Another test while the cpe's route hasn't been sent to area 0. If I disable the cpe's loopback interface (172.24.32.7/32) and enable it again, the 172.16.31.0/24 route comes back, but now the loopback route is missing from the area 0 and area 172.24.31.240 routers. This is also not true 100% of the times.

This is tested on

OSls update into area 0?packet trace
VyOS 1.1.7noo6-10411 to core router and o6-10411 to cpe
VyOS 1.2.0 beta 2017 10 02no
Vyatta VSE6.5R3no
Vyatta VSE6.7R3yeso6-10411 to core and o6-10411 to cpe
FRR 3.1yes
Variuos Cisco IOSyes

Here are another two corresponding traces where I disable and enable loopback and ether2 interface on 10411p-cpe001:

Core router to o6-10411:
o6-10411 to cpe:
  • I have not tested other topologies/areas than this.
  • I have tested disabling vrrp and running area on eth0/1.
  • It's the same behaviour on vyos 1.1.3 to vyos 1.2.0 latest nightly build.
  • When link goes up the LS Update is always sent into area 0 when using FRR 3.1, Vyatta 6.7R3 and other routers.
  • Wire captures are made as shown on topology picture.

My configuration on o6-10411, vrrp master:

set interfaces ethernet eth0 address '172.30.200.124/31'
set interfaces ethernet eth0 description '10411-LINK'
set interfaces ethernet eth0 duplex 'auto'
set interfaces ethernet eth0 hw-id '00:29:a8:95:49:00'
set interfaces ethernet eth0 ip ospf dead-interval '4'
set interfaces ethernet eth0 ip ospf hello-interval '1'
set interfaces ethernet eth0 ip ospf network 'broadcast'
set interfaces ethernet eth0 ip ospf priority '1'
set interfaces ethernet eth0 ip ospf retransmit-interval '5'
set interfaces ethernet eth0 ip ospf transmit-delay '1'
set interfaces ethernet eth0 smp_affinity 'auto'
set interfaces ethernet eth0 speed 'auto'
set interfaces ethernet eth0 vrrp vrrp-group 104 advertise-interval '1'
set interfaces ethernet eth0 vrrp vrrp-group 104 preempt 'false'
set interfaces ethernet eth0 vrrp vrrp-group 104 priority '150'
set interfaces ethernet eth0 vrrp vrrp-group 104 sync-group '10411'
set interfaces ethernet eth0 vrrp vrrp-group 104 virtual-address '172.24.0.89/29'
set interfaces ethernet eth1 address '172.30.201.56/31'
set interfaces ethernet eth1 description 'SERVICES-LINK'
set interfaces ethernet eth1 duplex 'auto'
set interfaces ethernet eth1 hw-id '00:29:a8:95:49:01'
set interfaces ethernet eth1 ip ospf dead-interval '4'
set interfaces ethernet eth1 ip ospf hello-interval '1'
set interfaces ethernet eth1 ip ospf network 'broadcast'
set interfaces ethernet eth1 ip ospf priority '1'
set interfaces ethernet eth1 ip ospf retransmit-interval '5'
set interfaces ethernet eth1 ip ospf transmit-delay '1'
set interfaces ethernet eth1 smp_affinity 'auto'
set interfaces ethernet eth1 speed 'auto'
set interfaces ethernet eth1 vrrp vrrp-group 104 advertise-interval '1'
set interfaces ethernet eth1 vrrp vrrp-group 104 preempt 'false'
set interfaces ethernet eth1 vrrp vrrp-group 104 priority '150'
set interfaces ethernet eth1 vrrp vrrp-group 104 sync-group '10411'
set interfaces ethernet eth1 vrrp vrrp-group 104 virtual-address '172.18.160.76/29'
set interfaces ethernet eth2 duplex 'auto'
set interfaces ethernet eth2 hw-id '00:29:a8:95:49:02'
set interfaces ethernet eth2 smp_affinity 'auto'
set interfaces ethernet eth2 speed 'auto'
set interfaces loopback lo address '172.18.255.14/32'
set protocols ospf area 0.0.0.0 network '172.18.0.0/16'
set protocols ospf area 172.24.0.88 area-type nssa 'no-summary'
set protocols ospf area 172.24.0.88 area-type nssa translate 'candidate'
set protocols ospf area 172.24.0.88 network '172.24.0.88/29'
set protocols ospf parameters abr-type 'cisco'
set protocols ospf parameters router-id '172.18.255.14'

cpe configuration (Mikrotik RouterOS)

/interface bridge
add name=loopback protocol-mode=none
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing ospf area
add area-id=172.24.0.88 default-cost=1 inject-summary-lsas=yes name=kunde \
    translator-role=translate-candidate type=nssa
/ip address
add address=172.24.0.90/29 interface=ether1 network=172.24.0.88
add address=172.16.31.1/24 interface=ether2 network=172.16.31.0
add address=172.24.32.7 interface=loopback network=172.24.32.7
/routing ospf interface
add dead-interval=4s hello-interval=1s interface=ether1 network-type=\
    broadcast
/routing ospf network
add area=kunde network=172.24.0.88/29
add area=kunde network=172.16.31.0/24
add area=kunde network=172.24.32.7/32

Details

Difficulty level
Unknown (require assessment)
Version
VyOS 1.1.3 to 1.2.0 2017 10 02 nightly build
Why the issue appeared?
Will be filled on close
olofl created this task.Oct 3 2017, 11:20 AM
olofl added a comment.EditedNov 3 2017, 2:45 PM

I just ran a test on http://dev.packages.vyos.net/tmp/vyos-1.2.0-alpha-frr-test.iso
OSPF now works as intended in this particular setup. The ABR now sends LS Update type 3 into core.

I'll just attach the captures here if they're out of interest.

syncer triaged this task as Low priority.Dec 21 2017, 9:44 PM
syncer changed the task status from Open to On hold.Oct 13 2018, 6:50 PM
syncer added a subscriber: syncer.

requires testing since w moved to frr

this seem to be solved since moving to frr.

syncer closed this task as Resolved.
syncer moved this task from Needs Triage to Finished on the VyOS 1.2.x (VyOS 1.2.0-rc8) board.
syncer claimed this task.