Cannot create vif interface attached to bridge group
Closed, ResolvedPublicBUG

Description

Yesterday I did a upgrade from 1.1.7 to 1.1.8 rc1. After the upgrade, my VLAN interface 'vif 22' that is bridged to my br0 interface dissapeard.
I tried to recreate the vif interface. But when commit the config, I get the following message:

admin@VPN-AMS1# commit
sa[ interfaces ethernet eth0 vif 22 ]
vlan: unknown command "-e"?
Usage: ... vlan [ protocol VLANPROTO ] id VLANID                [ FLAG-LIST ]
                [ ingress-qos-map QOS-MAP ] [ egress-qos-map QOS-MAP ]

VLANPROTO: [ 802.1Q / 802.1ad ]
VLANID := 0-4095
FLAG-LIST := [ FLAG-LIST ] FLAG
FLAG := [ reorder_hdr { on | off } ] [ gvrp { on | off } ] [ mvrp { on | off } ]
        [ loose_binding { on | off } ]
QOS-MAP := [ QOS-MAP ] QOS-MAPPING
QOS-MAPPING := FROM:TO
Error creating VLAN device eth0.22

[[interfaces ethernet eth0 vif 22]] failed
[[interfaces ethernet eth0 vif 22 bridge-group]] failed
Commit failed
ve

The relevant config that I try to commit:

bridge br0 {
     address 192.168.20.3/24
     aging 300
     description <DESCRIPTION>
     firewall {
         out {
             name BLOCK_X_OUT
         }
     }
     hello-time 2
     max-age 20
     priority 300
     stp true
 }
 ethernet eth0 {
     address 192.168.0.20/24
     address <IPv6_ADDRESS>
     description <DESCRIPTION>
     duplex auto
     hw-id 00:00:00:00:00:00
     policy {
         route <POLICY>
     }
     smp_affinity auto
     speed auto
     vif 20 {
         bridge-group {
             bridge br0
         }
         description <DESCRIPTION>
     }
 }

Details

Difficulty level
Unknown (require assessment)
Version
1.1.8rc1
Why the issue appeared?
Will be filled on close
S3m1r6 created this task.Fri, Oct 27, 8:27 PM
dmbaturin triaged this task as Unbreak Now! priority.
S3m1r6 updated the task description. (Show Details)Sat, Oct 28, 11:31 PM
syncer closed this task as Resolved.
dmbaturin reopened this task as Open.Mon, Oct 30, 4:06 PM

Not resolved yet. ;)

syncer closed this task as Resolved.Mon, Oct 30, 6:53 PM
dmbaturin reopened this task as In progress.Mon, Oct 30, 7:02 PM
dmbaturin added a subscriber: syncer.

@S3m1r6 Could you test this image? http://dev.packages.vyos.net/iso/testing/vyos-1.1.8-rc2-amd64.iso I tested loading a config similar to yours (with ingress/egress QoS values added to make sure they get processed) and it works for me.

@syncer Please do not mark tasks as resolved until the fix is confirmed. Ideally we should add a separate state/flag for tasks that are implemented but not yet tested, like we did in bugzilla.

will state - "fix testing required" work for us?

S3m1r6 removed dmbaturin as the assignee of this task.Thu, Nov 2, 12:16 PM
S3m1r6 added a subscriber: dmbaturin.

@dmbaturin I tested the new image. I can confirm that the problem is solved.

dmbaturin closed this task as Resolved.Thu, Nov 2, 3:42 PM
dmbaturin claimed this task.