Page MenuHomePhabricator

iBGP recursive route via OSPF-learned loopback next-hop selects (wrong) interface next-hop
Closed, InvalidPublic

Description

admin@vyos:~$ show ip route 192.168.5.17
Routing entry for 192.168.5.16/29
  Known via "bgp", distance 200, metric 1, best
  Last update 00:22:32 ago
  * 192.168.1.3 (recursive is directly connected, pppoe0)
admin@vyos:~$ show ip route 192.168.1.3
Routing entry for 192.168.1.3/32
  Known via "ospf", distance 110, metric 30, best
  Last update 00:22:51 ago
  * 192.168.1.66, via tun0
admin@vyos:~$ show ip bgp neighbors 192.168.1.2 received-routes 
BGP table version is 0, local router ID is 192.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.5.16/29   192.168.1.3               1    100      0 ?

Total number of prefixes 1
admin@vyos:~$ show ip ospf route 
============ OSPF network routing table ============
N    192.168.1.1/32         [10] area: 0.0.0.0
                           directly attached to lo
N    192.168.1.2/32         [20] area: 0.0.0.0
                           via 192.168.1.66, tun0
N    192.168.1.3/32         [30] area: 0.0.0.0
                           via 192.168.1.66, tun0
N    192.168.1.64/30        [10] area: 0.0.0.0
                           directly attached to tun0
N    192.168.1.72/30        [20] area: 0.0.0.0
                           via 192.168.1.66, tun0

============ OSPF router routing table =============
R    192.168.1.2            [10] area: 0.0.0.0, ASBR
                           via 192.168.1.66, tun0
R    192.168.1.3            [20] area: 0.0.0.0, ASBR
                           via 192.168.1.66, tun0

============ OSPF external routing table ===========

tcpdump confirms traffic is forwarded to pppoe0

Details

Difficulty level
Unknown (require assessment)
Version
999.201711232137
Why the issue appeared?
Will be filled on close

Event Timeline

Tiberius created this task.Dec 3 2017, 11:15 PM
Tiberius created this object in space S1 VyOS Public.

Rebooting the router fixed it...

Tiberius changed Version from 1.2 to 999.201711232137.Dec 4 2017, 1:37 AM
syncer triaged this task as Normal priority.Dec 21 2017, 9:10 PM
syncer changed the visibility from "Subscribers" to "Public (No Login Required)".Oct 13 2018, 7:14 PM
syncer changed the task status from Open to On hold.
syncer assigned this task to dmbaturin.
syncer added a subscriber: syncer.

@Tiberius please retest on the latest rolling

pasik added a subscriber: pasik.Nov 4 2018, 11:24 AM
syncer reassigned this task from dmbaturin to zsdc.Feb 7 2019, 11:53 PM
syncer changed the task status from On hold to Needs testing.
syncer added a subscriber: dmbaturin.
zsdc closed this task as Invalid.Feb 26 2019, 2:09 PM

I'm closing this ticket, because we don't have feedback from author for a long time nor configuration for reproducing this by ourselves.
If someone will meet with this bug with FRRouting-based versions of VyOS, please reopen.

syncer edited projects, added Invalid; removed VyOS 1.3 Equuleus.Mar 16 2019, 7:06 PM