Page MenuHomePhabricator

Package ipaddrcheck for VyOS 1.2.0
Closed, ResolvedPublic

Description

The existing tools for address checking in VyOS are often too broad for convenient checking. Split IPv4 and IPv6 VRRP (T616) makes this especially apparent, since we need to check for IPv4 OR IPv4 with prefix length, or IPv6 OR IPv6 with prefix length, but we don't have a ready to use tool.

ipaddrcheck was intended to solve exact this issue back in Vyatta, but somehow it never made it to the image. Time to fix it.

Details

Difficulty level
Unknown (require assessment)
Version
-
Why the issue appeared?
Will be filled on close
dmbaturin triaged this task as Normal priority.
dmbaturin created this object with visibility "Public (No Login Required)".
dmbaturin added a project: VyOS 1.2.x.
c-po added a subscriber: c-po.May 11 2018, 9:08 AM

For IP address or network checking I tried Python ipaddress package. https://github.com/c-po/vyos-1x/blob/current/src/conf-mode/vyos-config-ntp.py#L22

Looked ok to me.

dmbaturin closed this task as Resolved.May 22 2018, 5:53 AM

ALready packaged and actively used.