Page MenuHomePhabricator

Change broke bridging
Closed, ResolvedPublicBUG

Description

Some change between 1.2.0-rolling+201806010917 and 1.2.0-rolling+201806180337 broke my bridging connections so this it no longer got an IP address on the brX interfaces. Reverting to older build fixed it, will try to check in between builds later when I can tolerate more downtime.

Details

Difficulty level
Unknown (require assessment)
Version
1.2.0-rolling+201806180337
Why the issue appeared?
Will be filled on close
mb300sd created this task.Jun 18 2018, 8:26 PM
pasik added a subscriber: pasik.Jun 19 2018, 5:04 PM

@mb300sd Can you please share your config for the bridged interfaces?
I did a few tests and can't find any issues.

relevant parts below. The interfaces seem to be added to the bridge, but the bridge interface is not assigned an ip address.

bridge br0 {
   address 10.1.4.1/24
   aging 300
   description LAN_TVBox
   firewall {
       in {
           ipv6-name DROP6
           name LAN_TVBox_IN
       }
   }
   hello-time 2
   max-age 20
   priority 32768
   stp false
}

ethernet eth3 {
   /* Only VLANs 100-999 routed here from Hyper-V */
   duplex auto
   hw-id 00:15:5d:60:ff:02
   smp-affinity auto
   speed auto
   vif .......................
   vif 202 {
       bridge-group {
           bridge br0
       }
       description "LAN_TVBox NIC (Bridge br0)"
   }
}

openvpn vtun0 {
   bridge-group {
       bridge br0
       cost 100
   }
   description "LAN_TVBox Tunnel"
   device-type tap
   encryption aes256
   hash sha256
   mode site-to-site
   persistent-tunnel
   protocol udp
   remote-host 10.10.2.1
   shared-secret-key-file /config/auth/tvbridge.key
}

Little more testing..

The last working version was 1.2.0-rolling+201806150337, so it happened between it and vyos-1.2.0-rolling+201806151501.

Sorry, I'm still not able to reproduce your issue. I used the same config you posted, just changed the IPs and used 19,20 and the rolling from today, everything looks just good.
When you have the issue what is the output of ' sh interfaces detail | match br'.

syncer triaged this task as Low priority.Jun 30 2018, 12:36 AM
syncer added a subscriber: syncer.

Need some dumps to see what sent/received

Finally had some down time I could to use to debug this, but it appears to be fixed in the latest revisions. Going back to 201806151501 still breaks it though.

As far as I could tell before, it was triggered by my unique attempt to bridge a vlan to openvpn.

dmbaturin closed this task as Resolved.Aug 4 2018, 8:20 PM
dmbaturin claimed this task.
dmbaturin added a subscriber: dmbaturin.

Closing for now then, let's reopen if needed, or make a separate task for bridging openvpn with new interface types.