Page MenuHomePhabricator

IPv6 static route issue 1.2.0 frr image
Closed, ResolvedPublicBUG

Description

When loading the config from the previous running image 1.1.8 the static routes are not loaded.
In a route-map the following is done to blackhole every prefix learned from BGP
rule 10 set ipv6-next-hop global 2001:DB8:0:DEAD:BEEF::1

and in the static routes
static route6 2001:DB8:0:DEAD:BEEF::1/128 blackhole

Afterwards none of the static routes get applied.

protocols static route6 <myprefix/32> blackhole ]
% Nexthop interface cannot be Null0, reject or blackhole

The commit failes and FRRouting proces is stopped and automatically restarted shortly after, causing me to lose connection for a short while.

On a reboot loading the config fails and also the static routes are not applied.

Details

Difficulty level
Easy (less than an hour)
Version
1.2.0-20180824-frr
Why the issue appeared?
Will be filled on close

Event Timeline

Merijn created this task.Aug 24 2018, 1:48 PM

My impression was that is was related to the adding of ipv6-next-hop to a route-map.
But without the IPv6 static routes the config commits fine.
When adding the first IPv6 static route the error is shown.

I believe i found the cause in the following issue on FRRouting
https://github.com/FRRouting/frr/issues/1440

You have to specify Null0 and not null0.

--- /home/vyos/blackhole-node.def       2018-08-25 01:00:46.720584600 +0200
+++ /opt/vyatta/share/vyatta-cfg/templates/protocols/static/route6/node.tag/blackhole/node.def  2018-08-25 00:57:56.540584600 +0200
@@ -6,11 +6,11 @@
       fi

        vtysh -c "configure terminal" \
-          -c "no ipv6 route $VAR(../@) null0";
+          -c "no ipv6 route $VAR(../@) Null0";
      else
         if [ -n "$VAR(./distance/@)" ]; then
           DIST="$VAR(./distance/@)";
         fi;
         vtysh -c "configure terminal" \
-          -c "ipv6 route $VAR(../@) null0 $DIST";
+          -c "ipv6 route $VAR(../@) Null0 $DIST";
      fi;

With this change i can successfully add the IPv6 routes.

Merijn changed the task status from Open to In progress.Aug 24 2018, 11:06 PM
Merijn changed Difficulty level from Unknown (require assessment) to Easy (less than an hour).

Hi @Merijn,
FRR changed quite a few commands here and there, most are easy fixes indeed.

Thanks for the fix, I've done it in all places that use null0 (IPv4 and non-default tables too).

syncer closed this task as Resolved.Sep 1 2018, 2:37 PM
syncer claimed this task.
syncer triaged this task as Normal priority.
syncer edited projects, added VyOS 1.2 Crux (VyOS 1.2.0-rc1); removed VyOS 1.2 Crux.
syncer moved this task from Needs Triage to Finished on the VyOS 1.2 Crux (VyOS 1.2.0-rc1) board.