Page MenuHomePhabricator

interface openvpn vtunXX bridge-group bridge brXX not working
Open, NormalPublicBUG

Description

Error message:

[ interfaces openvpn vtun0 ]
device vtun0 is already a member of a bridge; can't enslave it to bridge br0.
Error adding interface vtun0 to bridge br0

Config snippet to reproduce:

+bridge br0 {
+}
+openvpn vtun0 {
+    bridge-group {
+        bridge br0
+        cost 100
+    }
+    local-port 1234
+    mode site-to-site
+    protocol udp
+    remote-host 1.1.1.1
+    remote-port 1234
+    shared-secret-key-file /config/auth/foo
+}

Another error happens if the bridge cost is not set inside the bridge-group:

[ interfaces openvpn vtun0 ]
set path cost failed: Numerical result out of range
Error setting bridge cost for vtun0

Details

Difficulty level
Unknown (require assessment)
Version
`1.2.0-rc1` and `1.2.0-rolling+201810090337`
Why the issue appeared?
Will be filled on close
afics created this task.Tue, Oct 9, 6:12 PM
syncer triaged this task as Normal priority.Wed, Oct 10, 2:17 PM
syncer edited projects, added VyOS 1.2.x (VyOS 1.2.0-rc2); removed VyOS 1.2.x.

The root cause was in the script trying to call "brctl setpathcost $bridge $port 0", but newer bridge-utils version removed that (there's no cost of zero in STP really, so it would be a rather bad way to set the default anyway).

Now we need to test if not setting it at all has the same effect as setting it to 0 used to have.

syncer closed this task as Resolved.
syncer claimed this task.
syncer reopened this task as Open.Sun, Oct 21, 4:35 PM