Page MenuHomePhabricator

Tunnels bridge-groups cannot be removed together with the bridge
Closed, ResolvedPublicBUG

Description

If a tunnel is in a bridge, and you try to delete the tunnel from a bridge and delete the bridge itself in one commit, the commit will fail, and you will be unable to commit anything else until reboot.

The cause is that, unlike in ethernet and friends, bridge group is handled by a half-baked custom script that assumes that the bridge exists.

Details

Difficulty level
Easy (less than an hour)
Version
1.1.8
Why the issue appeared?
Will be filled on close
syncer triaged this task as Normal priority.Oct 14 2018, 8:32 PM
syncer closed this task as Resolved.
syncer claimed this task.