Page MenuHomePhabricator

Intel 520 card requires modprobe option when using non-Intel SFP
Closed, ResolvedPublic

Description

When using the Intel 520 dual port 10-gig card, it is necessary to run the following routine:

Create:
/etc/modprobe.d/ixgbe-options.conf with the following directive: options ixgbe allow_unsupported_sfp=1

Then it has to be loaded with:

modprobe -vr ixgbe
modprobe ixgbe

Unfortunately, update-initramfs is disabled on 1.2, so the change is lost after a reboot

Details

Difficulty level
Unknown (require assessment)
Version
-1.2
Why the issue appeared?
Will be filled on close

Event Timeline

roger_roger created this object in space S1 VyOS Public.
roger_roger triaged this task as Unbreak Now! priority.
pasik added a subscriber: pasik.Nov 4 2018, 11:20 AM

Here is the dmesg | grep ixgbe output on startup:

[ 1.426059] ixgbe: Intel(R) 10 Gigabit PCI Express Network Driver - version 5.1.0-k
[ 1.426061] ixgbe: Copyright (c) 1999-2016 Intel Corporation.
[ 1.445112] ixgbe 0000:07:00.0: failed to load because an unsupported SFP+ or QSFP module type was detected.
[ 1.562564] ixgbe 0000:07:00.0: Reload the driver after installing a supported module.
[ 2.965466] ixgbe 0000:07:00.1: Multiqueue Enabled: Rx Queue count = 16, Tx Queue count = 16 XDP Queue count = 0
[ 2.965599] ixgbe 0000:07:00.1: PCI Express bandwidth of 32GT/s available
[ 2.965602] ixgbe 0000:07:00.1: (Speed:5.0GT/s, Width: x8, Encoding Loss:20%)
[ 2.965937] ixgbe 0000:07:00.1: MAC: 2, PHY: 1, PBA No: G18786-003
[ 2.965940] ixgbe 0000:07:00.1: 90:e2:ba:1e:17:05
[ 2.967911] ixgbe 0000:07:00.1: Intel(R) 10 Gigabit Network Connection
[ 16.450357] ixgbe 0000:07:00.1 eth3: renamed from eth2
[ 26.463139] ixgbe 0000:07:00.1: registered PHC device on eth3

I then ran this:
echo "options ixgbe allow_unsupported_sfp=1" > /etc/modprobe.d/ixgbe-options.conf
And then this:

modprobe -vr ixgbe
modprobe ixgbe

and that resulted in these messages:

[ 161.747072] ixgbe 0000:07:00.1: removed PHC on eth3
[ 162.181751] ixgbe 0000:07:00.1: complete
[ 167.137328] ixgbe: Intel(R) 10 Gigabit PCI Express Network Driver - version 5.1.0-k
[ 167.137330] ixgbe: Copyright (c) 1999-2016 Intel Corporation.
[ 167.156512] ixgbe 0000:07:00.0 0000:07:00.0 (uninitialized): WARNING: Intel (R) Network Connections are quality tested using Intel (R) Ethernet Optics. Using untested modules is not supported and may cause unstable operation or damage to the module or the adapter. Intel Corporation is not responsible for any harm caused by using untested modules.
[ 167.296093] ixgbe 0000:07:00.0: Multiqueue Enabled: Rx Queue count = 16, Tx Queue count = 16 XDP Queue count = 0
[ 167.296222] ixgbe 0000:07:00.0: PCI Express bandwidth of 32GT/s available
[ 167.296224] ixgbe 0000:07:00.0: (Speed:5.0GT/s, Width: x8, Encoding Loss:20%)
[ 167.296556] ixgbe 0000:07:00.0: MAC: 2, PHY: 19, SFP+: 5, PBA No: G18786-003
[ 167.296558] ixgbe 0000:07:00.0: 90:e2:ba:1e:17:04
[ 167.298140] ixgbe 0000:07:00.0: Intel(R) 10 Gigabit Network Connection
[ 168.370750] ixgbe 0000:07:00.0: invalid short VPD tag 00 at offset 1
[ 168.616026] ixgbe 0000:07:00.1: Multiqueue Enabled: Rx Queue count = 16, Tx Queue count = 16 XDP Queue count = 0
[ 168.616157] ixgbe 0000:07:00.1: PCI Express bandwidth of 32GT/s available
[ 168.616159] ixgbe 0000:07:00.1: (Speed:5.0GT/s, Width: x8, Encoding Loss:20%)
[ 168.616492] ixgbe 0000:07:00.1: MAC: 2, PHY: 1, PBA No: G18786-003
[ 168.616493] ixgbe 0000:07:00.1: 90:e2:ba:1e:17:05
[ 168.618087] ixgbe 0000:07:00.1: Intel(R) 10 Gigabit Network Connection

then ifconfig eth2 down and ifconfig eth2 up

The result is that the interface shows as up, yet when I try to ping an IP address on eth2, I get the following:
connect: Invalid argument
It should be noted that address on eth 2 is in a vif

I believe we have similar issue on the Intel i40e. FYI

syncer lowered the priority of this task from Unbreak Now! to Normal.

I think Intel now even recommends using Brocade 1gigabit modules for SFP+ modules when needing to down grade a 10G port to gigabit now, since they no longer manufacture 1G modules, so this is bound to bite people. Perhaps default to adding the allow_unsupported_sfp=1 for the various intel drivers perhaps?

The driver for the Intel X520-DA in Vyos 1.1.8 is version 3.15.1. Intel's latest driver version is 5.5.1

c-po added a subscriber: c-po.Nov 7 2018, 3:45 PM

T123 addressed exactly this issue but we not yet have agreed on a CLI yet. I do not know if it's safe to enable it in generall.

This comment was removed by MrFunken.
dmbaturin closed this task as Resolved.Dec 2 2018, 11:41 PM
dmbaturin claimed this task.
dmbaturin added a subscriber: dmbaturin.

This should have been resolved by https://github.com/vyos/vyos-build/commit/2896acaf144a6091576e10b65e477ea35243b3c2

Somehow I forgot to mention the task in the commit!

If the issue reappears, feel free to reopen.

Hi Guys,

This unfortunately doesn't fix the issue for cards with more than one port. From the modinfo:
parm: allow_unsupported_sfp:Allow unsupported and untested SFP+ modules on 82599 based adapters, default 0 = Disable (array of int)

For a dual port card, you must pass 1,1.. 1,1,1,1 for a quad port card etcetc.

I think revisiting T123 might be a good idea on this one.