Page MenuHomePhabricator

Maltahl (Frej)
User

Projects

User does not belong to any projects.

User Details

User Since
Mar 12 2018, 8:50 AM (57 w, 5 d)

Recent Activity

Fri, Mar 29

Maltahl added a comment to T1288: FRR: rewrite staticd backend (/opt/vyatta/share/vyatta-cfg/templates/protocols/static/*).

Feel free to add patches that needs testing.
I will report back my findings with my setup (as previously PMed about)

Fri, Mar 29, 7:51 PM · VyOS 1.2 Crux (VyOS 1.2.2), VyOS 1.3 Equuleus

Mar 5 2019

Maltahl added a comment to T1226: Wireguard not working between vyos routers 1.2.0.

No dice sadly. I think we have to close this since i have a feeling it might be more than 1 issue.
I think the problem with the bond vif interface not sending recieving is a critial error but i do not know how to report it correctly.
The other issue i think is related is the static routes not being applied.

Mar 5 2019, 8:41 AM · Invalid

Feb 27 2019

Maltahl added a comment to T1226: Wireguard not working between vyos routers 1.2.0.

Ye it works fine. How else would it be able to work before with same routers, same ips, same config ? I can also access services no problem on the remote site (reverse proxy) but not services on the local network on the remote site.

Feb 27 2019, 7:07 PM · Invalid

Feb 19 2019

Maltahl added a comment to T1226: Wireguard not working between vyos routers 1.2.0.

Tried both and they solved the issue but same problem with the tunnel not going up is the same.
I tried regen keys on both ends. No dice.

Feb 19 2019, 4:25 PM · Invalid

Feb 15 2019

Maltahl added a comment to T1226: Wireguard not working between vyos routers 1.2.0.

@hagbard is the patch for the validator issue in latest rolling or do you have a .deb i can apply ? :)

Feb 15 2019, 8:32 PM · Invalid

Feb 14 2019

Maltahl added a comment to T1218: Static routes not being applied in 1.2 Release.

i tried doing complete reinstalls and i can now confirm this bug as well.

Feb 14 2019, 8:51 AM · VyOS 1.3 Equuleus, VyOS 1.2 Crux (VyOS 1.2.1)

Feb 11 2019

Maltahl added a comment to T1226: Wireguard not working between vyos routers 1.2.0.

All right, let me know if you need help.

Feb 11 2019, 2:40 PM · Invalid

Feb 8 2019

Maltahl added a comment to T1226: Wireguard not working between vyos routers 1.2.0.

Will try to reinstall the baremetal router since it is the most inconsistant of the two routers. The virtual one works with other peers.

Feb 8 2019, 6:51 AM · Invalid

Feb 7 2019

Maltahl added a comment to T1226: Wireguard not working between vyos routers 1.2.0.

@Maltahl That smells more like an issue with your key setup. The wg interface listens on any interface which is up and running. If the traffic inside the wg interface doesn't show anything, that means it can't decrypt the traffic with your private key.

Feb 7 2019, 5:55 PM · Invalid
Maltahl added a comment to T1226: Wireguard not working between vyos routers 1.2.0.

@hagbard i have tried removing all firewall rules on both routers and checked that the wireguard module was running. i have also tried allowing all traffic and also allowed udp for the wireguard port when it arrived.

Feb 7 2019, 2:26 PM · Invalid

Feb 5 2019

Maltahl added a comment to T1226: Wireguard not working between vyos routers 1.2.0.

@Maltahl Let me know if you still need help, please. I put the task meanwhile on-hold.

Feb 5 2019, 1:24 PM · Invalid

Feb 2 2019

Maltahl added a comment to T1226: Wireguard not working between vyos routers 1.2.0.

@Maltahl Did you try the same with the rolling release? I don't see any issue with your config in particular, did you check that the wg traffic is actually getting to your router02?

Feb 2 2019, 9:49 PM · Invalid
Maltahl added a comment to T1226: Wireguard not working between vyos routers 1.2.0.
In T1226#32008, @runar wrote:

Hi! I see that your tunnels does not resides inside the same subnet, one devise is '10.0.90.1/24' and the other one '10.0.100.1/24'.. please move one of then to ip .2 in the subnet belonging to the other router.

Feb 2 2019, 3:16 PM · Invalid

Feb 1 2019

Maltahl added a comment to T1226: Wireguard not working between vyos routers 1.2.0.

Forgot to add version for both routers, sorry.

Feb 1 2019, 11:36 PM · Invalid
Maltahl created T1226: Wireguard not working between vyos routers 1.2.0.
Feb 1 2019, 11:31 PM · Invalid
Maltahl added a comment to T1218: Static routes not being applied in 1.2 Release.

Wierd, i cannot reproduce this on LTS 1.2.0 on both baremetal and virtual instances.

Feb 1 2019, 9:57 PM · VyOS 1.3 Equuleus, VyOS 1.2 Crux (VyOS 1.2.1)

Jan 30 2019

Maltahl added a comment to T1217: 1.2.0 LTS cant delete wireguard wg0 interface.
fma@glos1ce1dk:~$ sh ver
Version:          VyOS 1.2.0
Built by:         Sentrium S.L.
Built on:         Sun 27 Jan 2019 19:08 UTC
Build ID:         795d6338-c1ce-4ebb-992f-d064f5af9309
Jan 30 2019, 10:36 PM · VyOS 1.2 Crux (VyOS 1.2.1)
Maltahl created T1217: 1.2.0 LTS cant delete wireguard wg0 interface.
Jan 30 2019, 10:07 PM · VyOS 1.2 Crux (VyOS 1.2.1)

Oct 27 2018

Maltahl added a comment to T886: validation logic in `interfaces wireguard wgX address x.x.x.x broken.

Thanks hagbard!
I was litterally pulling my hair out over the error cause i have seen wireguard work in all its glory.
If i want to apply the patch on my own are there any resources i should use or is it simply a dpkg install ?

Oct 27 2018, 10:34 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-rc2)

Oct 26 2018

Maltahl added a comment to T886: validation logic in `interfaces wireguard wgX address x.x.x.x broken.

This is still not added to rc3 and rc4 same error

Oct 26 2018, 7:55 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-rc2)

Oct 16 2018

Maltahl added a comment to T886: validation logic in `interfaces wireguard wgX address x.x.x.x broken.

Was this by any chance merged to RC3 or will it first arrive in RC4 ?

Oct 16 2018, 5:52 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-rc2)

Oct 10 2018

Maltahl reassigned T774: Wireguard: Write wiki documentation from Maltahl to hagbard.

Here is the pastebin since im still not allowed to post on the wiki
https://pastebin.com/sZcJLyeB

Oct 10 2018, 6:29 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-rc3), Restricted Project

Oct 8 2018

Maltahl added a comment to T774: Wireguard: Write wiki documentation.

I tried adding the wiki updates last saturday without any luck ( was not allowed to post updates )
Will post a pastebin with wiki text for review later today

Oct 8 2018, 10:49 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-rc3), Restricted Project

Oct 5 2018

Maltahl added a comment to T774: Wireguard: Write wiki documentation.

@hagbard status so far is that i am nearly done with 3 types of setups with minor edits on existing wiki documentation for wireguard as it was not updated to match current commands :)
There is also some clearification on what each segment of the config is to avoid confusion newcomers that want to try it out.
I will add it after work today.

Oct 5 2018, 6:19 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-rc3), Restricted Project

Oct 3 2018

Maltahl added a comment to T774: Wireguard: Write wiki documentation.
In T774#20257, @hagbard wrote:

Hang on a sec, have a look here:
https://github.com/vyos/vyos-documentation

Oct 3 2018, 6:28 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-rc3), Restricted Project

Oct 2 2018

Maltahl added a comment to T774: Wireguard: Write wiki documentation.

@hagbard thanks for the awesome implementation of wireguard to vyos.

Oct 2 2018, 8:20 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-rc3), Restricted Project

Aug 28 2018

Maltahl added a comment to T787: DMVPN on 1.2.0.

@c-po i have redacted the parts of the config i dont want leaked and i will just change the passphase :)

Aug 28 2018, 7:42 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-rc1)

Aug 27 2018

Maltahl added a comment to T787: DMVPN on 1.2.0.

trying to setup DMVPN HUB using the wiki as reference on 1.2.0-rolling+201808272007

Aug 27 2018, 9:25 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-rc1)