Page MenuHomeVyOS Platform

byteshifter (Michael Agbaglo)
User

Projects

User does not belong to any projects.

User Details

User Since
Mar 2 2019, 9:41 AM (195 w, 3 d)

Recent Activity

Mar 6 2019

byteshifter added a comment to T1276: dhcp relay + VLAN fails.

Alpine Linux and OPNsense make it without "cheat mode" (ethtool).
I used the virt-install / bash script above for all.

Mar 6 2019, 8:51 PM · VyOS 1.3 Equuleus (1.3.3), VyOS 1.4 Sagitta, test

Mar 5 2019

byteshifter added a comment to T1276: dhcp relay + VLAN fails.

@c-po :

4.3 branch is End of life (EOL) as of July 2018

https://www.isc.org/downloads/

Mar 5 2019, 4:00 PM · VyOS 1.3 Equuleus (1.3.3), VyOS 1.4 Sagitta, test
byteshifter added a comment to T1276: dhcp relay + VLAN fails.

@c-po

Mar 5 2019, 11:47 AM · VyOS 1.3 Equuleus (1.3.3), VyOS 1.4 Sagitta, test
byteshifter added a comment to T1276: dhcp relay + VLAN fails.

@c-po
Not sure what you meant by your first sentence.

Mar 5 2019, 10:16 AM · VyOS 1.3 Equuleus (1.3.3), VyOS 1.4 Sagitta, test
byteshifter added a comment to T1276: dhcp relay + VLAN fails.

@varesa Currently there is no way to specify upstream and downstream interfaces in vyos. If vyos was relying on isc dhcp relay from the beginning, how are upstream and downstream interfaces expected to be specified?

Mar 5 2019, 5:20 AM · VyOS 1.3 Equuleus (1.3.3), VyOS 1.4 Sagitta, test

Mar 4 2019

byteshifter added a comment to T1276: dhcp relay + VLAN fails.

@Gislaved : No, VM is down. Alpine Linux is up. Have to make progress, project is delayed.
No problems with opnsense VM or Alpine Linux VM regarding DHCPv4 relaying.

Mar 4 2019, 10:16 PM · VyOS 1.3 Equuleus (1.3.3), VyOS 1.4 Sagitta, test
byteshifter added a comment to T1276: dhcp relay + VLAN fails.

@varesa : DHCP server is reachable via eth0. No DHCP service for eth0. Will not add that command. vyos has to work w/o.

Mar 4 2019, 10:15 PM · VyOS 1.3 Equuleus (1.3.3), VyOS 1.4 Sagitta, test
byteshifter added a comment to T1276: dhcp relay + VLAN fails.

virt-install \
--network bridge:br0 \
--name ${NAME} \
--ram 512 \
--vcpus 1 \
--disk /var/lib/libvirt/images/${NAME}.qcow2,size=2 \
--graphics none \
--os-type linux --os-variant debian9 \
--cdrom=/tmp/vyos-1.2.0-rolling+201902120337-amd64.iso \
--noreboot

Mar 4 2019, 7:11 PM · VyOS 1.3 Equuleus (1.3.3), VyOS 1.4 Sagitta, test
byteshifter added a comment to T1276: dhcp relay + VLAN fails.

[email protected]:~$ sh conf commands
set interfaces ethernet eth0 address '172.16.0.1/24'
set interfaces ethernet eth0 address 'fd00::1/64'
set interfaces ethernet eth0 duplex 'auto'
set interfaces ethernet eth0 hw-id '52:54:00:7a:87:b1'
set interfaces ethernet eth0 smp-affinity 'auto'
set interfaces ethernet eth0 speed 'auto'
set interfaces ethernet eth1 duplex 'auto'
set interfaces ethernet eth1 hw-id '52:54:00:4b:73:5f'
set interfaces ethernet eth1 smp-affinity 'auto'
set interfaces ethernet eth1 speed 'auto'
set interfaces ethernet eth1 vif 40 address '172.16.40.1/24'
set interfaces ethernet eth1 vif 41 address '172.16.41.1/24'
set interfaces ethernet eth1 vif 42 address '172.16.42.1/24'
set interfaces ethernet eth1 vif 60 address 'fd00:60::1/64'
set interfaces ethernet eth1 vif 61 address 'fd00:61::1/64'
set interfaces ethernet eth1 vif 62 address 'fd00:62::1/64'
set interfaces ethernet eth1 vif 100 address 'fd00:100::1/64'
set interfaces ethernet eth1 vif 100 address '172.16.100.1/24'
set interfaces ethernet eth1 vif 101 address 'fd00:101::1/64'
set interfaces ethernet eth1 vif 101 address '172.16.101.1/24'
set interfaces ethernet eth1 vif 102 address 'fd00:102::1/64'
set interfaces ethernet eth1 vif 102 address '172.16.102.1/24'
set interfaces ethernet eth2 address 'dhcp'
set interfaces ethernet eth2 duplex 'auto'
set interfaces ethernet eth2 hw-id '52:54:00:10:84:02'
set interfaces ethernet eth2 smp-affinity 'auto'
set interfaces ethernet eth2 speed 'auto'
set interfaces loopback lo
set nat source rule 100 outbound-interface 'eth2'
set nat source rule 100 translation address 'masquerade'
set service dhcp-relay interface 'eth1.40'
set service dhcp-relay interface 'eth1.41'
set service dhcp-relay interface 'eth1.42'
set service dhcp-relay interface 'eth1.100'
set service dhcp-relay interface 'eth1.101'
set service dhcp-relay interface 'eth1.102'
set service dhcp-relay relay-options relay-agents-packets 'discard'
set service dhcp-relay server '172.16.0.10'
set service mdns repeater interface 'eth1.40'
set service mdns repeater interface 'eth1.41'
set service ssh listen-address '172.16.0.1'
set service ssh listen-address 'fd00::1'
set service ssh port '22'
set system config-management commit-revisions '100'
set system console device ttyS0 speed '9600'
set system host-name 'vyos'
set system login user vyos authentication encrypted-password '[deleted: what else?]'
set system login user vyos authentication plaintext-password ''
set system login user vyos level 'admin'
set system ntp server 0.pool.ntp.org
set system ntp server 1.pool.ntp.org
set system ntp server 2.pool.ntp.org
set system syslog global facility all level 'info'
set system syslog global facility protocols level 'debug'
set system time-zone 'Europe/Berlin'
[email protected]:~$

Mar 4 2019, 7:03 PM · VyOS 1.3 Equuleus (1.3.3), VyOS 1.4 Sagitta, test
byteshifter added a comment to T1276: dhcp relay + VLAN fails.

My setup is different:

Mar 4 2019, 6:06 PM · VyOS 1.3 Equuleus (1.3.3), VyOS 1.4 Sagitta, test

Mar 2 2019

byteshifter created T1276: dhcp relay + VLAN fails.
Mar 2 2019, 9:54 AM · VyOS 1.3 Equuleus (1.3.3), VyOS 1.4 Sagitta, test