Page MenuHomeVyOS Platform

VyOS 1.2 Crux ( VyOS 1.2.0-rc11)Milestone
ArchivedPublic

Members

  • This project does not have any members.
  • View All

Watchers

  • This project does not have any watchers.
  • View All

Recent Activity

Jan 30 2019

mdsmds created T1213: ddclient not functional in the S1 VyOS Public space.
Jan 30 2019, 8:10 AM · VyOS 1.2 Crux (VyOS 1.2.1)

Jan 3 2019

syncer archived VyOS 1.2 Crux ( VyOS 1.2.0-rc11).
Jan 3 2019, 1:53 PM

Dec 21 2018

syncer moved T1033: build-ami: Enable support for ENA from Needs Triage to Finished on the VyOS 1.2 Crux ( VyOS 1.2.0-rc11) board.
Dec 21 2018, 10:10 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11), build-ami, AWS Support
syncer moved T1047: Configuration saved on a livecd cannot be carried over to the installed image from Needs Triage to Finished on the VyOS 1.2 Crux ( VyOS 1.2.0-rc11) board.
Dec 21 2018, 10:10 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
syncer moved T1048: [IPSec] Protocol all does not work in IPSec Tunnel from Needs Triage to Finished on the VyOS 1.2 Crux ( VyOS 1.2.0-rc11) board.
Dec 21 2018, 10:10 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
syncer moved T1065: PPPoE MTU on boot up from Needs Triage to Finished on the VyOS 1.2 Crux ( VyOS 1.2.0-rc11) board.
Dec 21 2018, 10:10 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
syncer moved T1064: dhcp relay with VRRP from Needs Triage to Finished on the VyOS 1.2 Crux ( VyOS 1.2.0-rc11) board.
Dec 21 2018, 10:10 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
syncer moved T1063: Routing protocol and QoS templates are missing in the wireguard CLI from Needs Triage to Finished on the VyOS 1.2 Crux ( VyOS 1.2.0-rc11) board.
Dec 21 2018, 10:10 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
syncer moved T1093: Cannot delete route-map with BGP community from Needs Triage to Finished on the VyOS 1.2 Crux ( VyOS 1.2.0-rc11) board.
Dec 21 2018, 10:10 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
syncer moved T1087: Firewall commands are missing in wireguard interface CLI from Needs Triage to Finished on the VyOS 1.2 Crux ( VyOS 1.2.0-rc11) board.
Dec 21 2018, 10:10 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
syncer moved T1072: Route-map rules do not allow named community-lists from Needs Triage to Finished on the VyOS 1.2 Crux ( VyOS 1.2.0-rc11) board.
Dec 21 2018, 10:10 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
syncer moved T1091: Incomplete autocompletion and description at "set service dns forwarding dnssec" from Needs Triage to Finished on the VyOS 1.2 Crux ( VyOS 1.2.0-rc11) board.
Dec 21 2018, 10:10 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
syncer moved T1111: Misbehaviour of "recent" options in firewall rules from Needs Triage to Finished on the VyOS 1.2 Crux ( VyOS 1.2.0-rc11) board.
Dec 21 2018, 10:10 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
syncer moved T1103: adding 'set interfaces wireguard wg01 ip and ipv6' options from Needs Triage to Finished on the VyOS 1.2 Crux ( VyOS 1.2.0-rc11) board.
Dec 21 2018, 10:10 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
syncer moved T1115: PPPoE interface is down from Needs Triage to Finished on the VyOS 1.2 Crux ( VyOS 1.2.0-rc11) board.
Dec 21 2018, 10:10 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)

Dec 20 2018

danhusan added a comment to T1120: rc11 raid-1 array wont come up on boot.

And FYI, just to make sure that something wasn't triggered by hanging out in GRUB.
rootdelay=0 fails
rootdelay=2 works, so just a small pause is needed on my system at least.

Dec 20 2018, 9:43 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
danhusan added a comment to T1120: rc11 raid-1 array wont come up on boot.

@kroy you are clearly on a roll today, rootdelay=10 also did the trick.

Dec 20 2018, 9:33 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
kroy added a comment to T1120: rc11 raid-1 array wont come up on boot.

@danhusan I'd be curious if an alternative of adding rootdelay=10 instead of the acpi=off works. That may or may not do anything depending on how the kernel is built though.

Dec 20 2018, 5:46 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
kroy added a comment to T1120: rc11 raid-1 array wont come up on boot.

Yeah, I'm not familiar enough with things to understand why it would be trying to mount the bare RAID partitions, not to mention the actual bare drives

Dec 20 2018, 5:38 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
danhusan added a comment to T1120: rc11 raid-1 array wont come up on boot.

Spot on, booting with acpi=off makes it come up properly and configurations are actually saved.
Still getting some errors but not sure if they matter or not:

Dec 20 2018, 5:28 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
kroy added a comment to T1120: rc11 raid-1 array wont come up on boot.

While I'm not sure if it's related, it looks like your system has a buggy ACPI implementation. Sometimes that can cause some weird behaviour.

Dec 20 2018, 5:12 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
danhusan added a comment to T1120: rc11 raid-1 array wont come up on boot.

Some data I wasn't able to find in any log files:

Dec 20 2018, 5:02 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
danhusan added a comment to T1120: rc11 raid-1 array wont come up on boot.

https://forum.vyos.io/t/vyos-1-2-0rc10-raid-1-fresh-install-unable-to-save-config/3059
These users might have the same issue. I noticed one of the symptoms of having the system is in this state is that the config is lost between reboots.

Dec 20 2018, 2:49 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
danhusan added a comment to T1120: rc11 raid-1 array wont come up on boot.

I am not able to reproduce it in vmware workstation.

Dec 20 2018, 2:47 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
c-po added a comment to T1120: rc11 raid-1 array wont come up on boot.

Does the problem occur on a virtual environment e.g. ESXi, too?

Dec 20 2018, 2:45 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
danhusan added a comment to T1120: rc11 raid-1 array wont come up on boot.

I can let it sit forever, the status wont change as the array is missing one disk. Notice how after (auto read only) raid1 is only says sdb1[0] (sda1 is missing).
Also we can see that this wont fix itself from looking at the df -h output where the system clearly has booted straight from sda1 instead of from the raid array (/dev/md127)

Dec 20 2018, 11:25 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
kroy added a comment to T1120: rc11 raid-1 array wont come up on boot.

I’ve been trying to research this a little, and I can’t duplicate. But I suspect it’s because I have fast disk. Your first output says it’s going to take over two hours for a resync.

Dec 20 2018, 6:29 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
kroy added a comment to T1020: OSPF Stops distributing default route after a while.

I pulled down vyos-frr submodule and the above-mentioned commit is present.

Dec 20 2018, 5:15 AM · VyOS 1.2 Crux (VyOS 1.2.5), VyOS 1.3 Equuleus

Dec 19 2018

danhusan added a comment to T1120: rc11 raid-1 array wont come up on boot.

After reboot, running from local disks:

Dec 19 2018, 10:37 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
danhusan added a comment to T1120: rc11 raid-1 array wont come up on boot.

During install (booted from ISO):

Dec 19 2018, 10:34 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
danhusan added a project to T1120: rc11 raid-1 array wont come up on boot: VyOS 1.2 Crux ( VyOS 1.2.0-rc11).
Dec 19 2018, 10:26 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
c-po closed T1064: dhcp relay with VRRP as Invalid.
Dec 19 2018, 10:00 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
SteveP added a comment to T1064: dhcp relay with VRRP.

I have just re-tested this with RC11 and can confirm that it was a
configuration error. I had moved the DHCP server to a different VLAN which
was not listed under dhcp-relay {

Dec 19 2018, 6:56 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
MrFunken added a comment to T865: Add initial RPKI support.

I can confirm the error mentioned by MrXermon.

Dec 19 2018, 9:35 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-GA)

Dec 18 2018

mpoublon added a comment to T777: Misleading Help Text for IPSEC Connection Type.

I've confirmed that the same is true for 1.2 RC11 as for 1.1.8

Dec 18 2018, 9:38 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA2)
MrXermon added a comment to T865: Add initial RPKI support.

Looks like the cache server is pushed into the FRR configuration multiple times if the configuration get's updated.

Dec 18 2018, 7:46 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-GA)
hagbard changed the status of T989: accel-ppp: IPoE implementation from On hold to In progress.
Dec 18 2018, 7:17 PM · VyOS 1.3 Equuleus
hagbard changed the status of T989: accel-ppp: IPoE implementation, a subtask of T742: Implement accel-ppp in VyOS, from On hold to In progress.
Dec 18 2018, 7:17 PM · VyOS 1.3 Equuleus
Barrysdca added a comment to T1026: Removing tunnel deletes all tunnels?.

I can test this on Saturday. Sorry was sick last few days, couldn't test anything.

Dec 18 2018, 6:07 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
hagbard changed the status of T1026: Removing tunnel deletes all tunnels? from In progress to On hold.
Dec 18 2018, 6:06 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
hagbard added a comment to T1026: Removing tunnel deletes all tunnels?.

@Barrysdca Can you please test with the latest rolling release, please?

Dec 18 2018, 6:05 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-EPA3)
hagbard reassigned T1028: Suspending and resuming VyOS in VMware will result in loss of static ip addresses from hagbard to Unicron.

@Unicron Can you please integrate the package below into ci?
https://github.com/vyos/vyos-vmwaretools-scripts

Dec 18 2018, 6:05 PM · VyOS 1.3 Equuleus
kroy added a comment to T1020: OSPF Stops distributing default route after a while.

Maybe this isn't the same issue? Still a problem in RC11 unfortunately.

Dec 18 2018, 5:09 PM · VyOS 1.2 Crux (VyOS 1.2.5), VyOS 1.3 Equuleus
trystan added a comment to T1087: Firewall commands are missing in wireguard interface CLI.

Everything is still working/functioning in the latest RC (1.2.0-rc11)

Dec 18 2018, 1:51 PM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
MrXermon added a comment to T865: Add initial RPKI support.

I tested it on one of my border routers today and it seems to be working with IPv6 (dropping 692 routes because of invalid ROA state). Sadly i am unable to test IPv4 at the moment.

Dec 18 2018, 9:34 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux (VyOS 1.2.0-GA)
dongjunbo added a comment to T1115: PPPoE interface is down.

Sorry, It's my cable was broken.

Dec 18 2018, 3:51 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
dongjunbo closed T1115: PPPoE interface is down as Invalid.
Dec 18 2018, 3:50 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
dongjunbo changed Version from vyos 1.2 lts to vyos 1.2 rc11 on T1115: PPPoE interface is down.
Dec 18 2018, 1:20 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
dongjunbo updated the task description for T1115: PPPoE interface is down.
Dec 18 2018, 1:19 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)
dongjunbo created T1115: PPPoE interface is down.
Dec 18 2018, 1:19 AM · VyOS-1.2.0-GA, VyOS 1.2 Crux ( VyOS 1.2.0-rc11)