Page MenuHomeVyOS Platform

Disabled Bonding Interfaces Enabled on Boot
Closed, ResolvedPublicBUG

Description

On the most recent rolling release (and I believe every release even back to RC10), any bonded interfaces that is set to disabled will still be enabled on boot. Here's an example:

Here's what I started with:

vyos@cr02-vyos:~$ show interfaces bonding bond1
bond1: <BROADCAST,MULTICAST,MASTER,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 52:54:00:bb:99:6a brd ff:ff:ff:ff:ff:ff
    inet 1.1.1.1/18 brd 255.255.255.255 scope global bond1
       valid_lft forever preferred_lft forever
    inet6 fe80::5054:ff:febb:996a/64 scope link 
       valid_lft forever preferred_lft forever
    Description: Time Warner Cable WAN

    RX:  bytes    packets     errors    dropped    overrun      mcast
     873289326    1664619          0          0          0          0
    TX:  bytes    packets     errors    dropped    carrier collisions
      49164758     246615          0          0          0          0

I disabled the interface and saved:

vyos@cr02-vyos:~$ configure
[edit]
vyos@cr02-vyos# set interfaces bonding bond1 disable
[edit]
vyos@cr02-vyos# commit
[edit]
vyos@cr02-vyos# save
Saving configuration to '/config/config.boot'...
Done
[edit]
vyos@cr02-vyos# exit
exit

I checked to verify that it is indeed disabled and rebooted:

vyos@cr02-vyos:~$ show interfaces bonding bond1
bond1: <BROADCAST,MULTICAST,MASTER> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 52:54:00:bb:99:6a brd ff:ff:ff:ff:ff:ff
    Description: Time Warner Cable WAN

    RX:  bytes    packets     errors    dropped    overrun      mcast
     896965638    1732172          0          0          0          0
    TX:  bytes    packets     errors    dropped    carrier collisions
      54675630     255524          0          0          0          0
vyos@cr02-vyos:~$ reboot
Are you sure you want to reboot this system? [y/N] y
packet_write_wait: Connection to UNKNOWN port 65535: Broken pipe

Lo and behold, it is still enabled on boot, but it shows as being disabled in the config:

vyos@cr02-vyos:~$ show configuration commands | grep 'bonding bond1 disable'
set interfaces bonding bond1 disable
vyos@cr02-vyos:~$ show interfaces bonding bond1
bond1: <BROADCAST,MULTICAST,MASTER,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 52:54:00:bb:99:6a brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5054:ff:febb:996a/64 scope link 
       valid_lft forever preferred_lft forever
    Description: Time Warner Cable WAN

    RX:  bytes    packets     errors    dropped    overrun      mcast
       8331930     138027          0          0          0          0
    TX:  bytes    packets     errors    dropped    carrier collisions
           746          7          0          0          0          0

Details

Difficulty level
Normal (likely a few hours)
Version
1.2 0, 1.2.0-rolling+201902251818 - 1.2RC10 (maybe more?)
Why the issue appeared?
Will be filled on close

Event Timeline

trae32566 changed Version from 1.2.0-rolling+201902230337 to 1.2 0 Final, 1.2.0-rolling+201902251818 - 1.2RC10 (maybe more?).Feb 26 2019, 4:54 AM

This bug is confirmed present on 1.2.0 final release as well.

trae32566 triaged this task as Normal priority.Mar 13 2019, 5:43 PM
trae32566 changed Version from 1.2 0 Final, 1.2.0-rolling+201902251818 - 1.2RC10 (maybe more?) to 1.2 0, 1.2.0-rolling+201902251818 - 1.2RC10 (maybe more?).

Added a priority of normal, as this could potentially cause outages (situations where the interface comes up and causes an IP conflict, or causes dynamic routing issues due to the connected route)

hagbard claimed this task.Mar 22 2019, 9:27 PM
hagbard changed the task status from Open to Confirmed.Mar 22 2019, 9:40 PM
hagbard changed Difficulty level from Unknown (require assessment) to Normal (likely a few hours).
pasik added a subscriber: pasik.Mar 23 2019, 9:19 PM
trae32566 closed this task as Resolved.Apr 2 2019, 4:39 AM

@hagbard This now works; I tested with 1.2.0-rolling+201904010337. Thanks!