Page MenuHomeVyOS Platform

Unable to boot VyOS 1.1.7 on a Mini-ITX device
Closed, ResolvedPublic

Description

Unable to boot VyOS 1.1.7 on a Mini-ITX device which has USB3 and USB2 ports. Got below error:

"Unable to find a medium containing live filesystem"
"/bin/sh: can't access tty; job control turned off"

MinITX spec:

H170M-ITX
128Mb AMI UEFI Legal BIOS with multilingual GUI
http://www.e-itx.com/itx350-h170m-itx-ac.html

Details

Difficulty level
Normal (likely a few hours)
Version
-

Event Timeline

rambeats created this task.Nov 9 2016, 5:46 PM

I had the same message when installing from a USB Key.
It was solved by disabling XHCI and enabling EHCI instead in BIOS.

XHCI mode cannot be disabled on certain hardware, like the relatively common PC Engines APU2 series boards. The current betas seem to be able to boot just fine, though.

I just tried to boot VyOS 1.1.7 64-bit from PCENGINES APU2C4 and got the exact same error message when installing from a USB key.

Is there any way to install current 1.1.7 on these machines?

I guess I'll try the 1.2 BETA next.
Is the BETA pretty much working or what problems does it have?

I was able to boot the 1.2 BETA with no problem. Is it stable enough to use?

Is there a way to easily fix this issue in 1.1.7 and re-issue a new version 1.1.8?

Also, I've successfully installed the free (requires registration) VMWARE ESXI 6.0 U2 (but not 6.5, it currently has a bug that prevented installing) on the PCENGINES APU2C4 with a 16GB SSD. I was able to mount CD ISO image from ESXI NFS client across the network to the server to install VyOS.

I was then able to set up VyOS 1.1.7 64-bit (Virtual) as a VM, so this is probably how I'm going to get around this problem for the moment.

syncer closed this task as Resolved.Aug 1 2017, 4:44 AM
syncer triaged this task as Normal priority.
syncer changed the edit policy from "Task Author" to "Custom Policy".
syncer changed Difficulty level from Easy (less than an hour) to Normal (likely a few hours).
syncer set Version to -.

seems to be support request and it's solved

jd added a subscriber: jd.May 27 2018, 12:54 PM

Hi,
Could not install stable 1.1.8 on PCEngines APU2C4. Apparently, the issue is not fixed in 1.1.8. Any way to make it work?
Will Beta 1.2.0 work?