Page MenuHomeVyOS Platform

BGP configuration failed
Closed, ResolvedPublicBUG

Description

Hi,

updated my VyOS VM with latest rolling version and it seems BGP got kinda screwed.

[email protected]# run show bgp vrf all sum
% No BGP neighbors found in VRF default
[edit]
[email protected]# run show bgp sum
% No BGP neighbors found in VRF default
[edit]
[email protected]# show protocols bgp | strip-private
 address-family {
     ipv4-unicast {
     }
 }
 local-as 64501
 neighbor xxx.xxx.10.252 {
     interface {
         source-interface eth0
     }
     remote-as XXXXXX
     update-source eth0
 }
 neighbor xxx.xxx.50.241 {
     remote-as XXXXXX
 }
 neighbor xxx.xxx.50.242 {
     remote-as XXXXXX
 }
 parameters {
     router-id xxx.xxx.50.253
 }
[edit]
[email protected]# run show system image
The system currently has the following image(s) installed:

   1: 1.4-rolling-202201120317 (default boot) (running image)
   2: 1.4-rolling-202201110811

[edit]

As you can see there is a bgp configuration in place but "show bgp summary" or "show bgp vrf all summary" not yielding any information.
And as it seems it's not only the "show" commands that not yield any information. BGP is not established at all with the configuration (was working fine with 1.4-rolling-202109280217).

Cheers

Details

Difficulty level
Unknown (require assessment)
Version
1.4-rolling-202201120317
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Unspecified (possibly destroys the router)
Issue type
Bug (incorrect behavior)

Event Timeline

Add neighbors to their proper afi:

set protocols bgp neighbor x.x.x.x address-family ipv4-unicast

thanks, working.

but wasn't necessary on VyOS 1.4-rolling-202109280217
so I guess changes to FRR that are the cause right?

anyways you can close the bug report then.