Page MenuHomePhabricator

VYOS do not restart hostapd service once new channel is set for AP
Closed, ResolvedPublicBUG

Description

I use 'set interface wireless wlan0 channel <channel name>' command to set the channel for AP. But after setting channel for the first time, when i tried to change the channel to different one , using same command , I found AP do not seem to take effect.
I can confirm that new channel number is getting updated in the /var/run/hostapd/wlan0.cfg file, but AP do not switch to the new channel.

If I manually restart hostapd service using 'hostapd-init restart wlan0' my AP do work with the latest channel.

Details

Difficulty level
Easy (less than an hour)
Version
1.2 20180528
Why the issue appeared?
Will be filled on close

Event Timeline

nirmal created this task.Jul 12 2018, 4:18 PM
hagbard claimed this task.Jul 12 2018, 5:25 PM
syncer triaged this task as Normal priority.Jul 20 2018, 12:42 PM
hagbard changed the task status from Open to In progress.Jul 29 2018, 8:46 PM

Problem happens in ln 27 in /opt/vyatta/share/vyatta-cfg/templates/interfaces/wireless/node.def, $VAR seems to be empty.

hagbard moved this task from In Progress to Finished on the VyOS 1.2 Crux board.Jul 29 2018, 10:02 PM

pending merge

hagbard closed this task as Resolved.Jul 30 2018, 3:11 PM