Page MenuHomeVyOS Platform
Authored By
Viacheslav
Mar 29 2020, 1:17 PM
Size
1 KB
Referenced Files
None
Subscribers
None

right-r1

set interfaces bridge br11 description 'For-vxlan11'
set interfaces ethernet eth0 address '22.22.22.3/24'
set interfaces ethernet eth1 bridge-group bridge 'br11'
set protocols bgp 65001 parameters default no-ipv4-unicast
set protocols bgp 65001 parameters router-id '22.22.22.3'
set protocols bgp 65001 peer-group fabric capability extended-nexthop
set protocols bgp 65001 peer-group fabric remote-as '65001'
set system host-name 'right-r1'
### Autostart commands ###
sudo nano -c /config/scripts/vyos-postconfig-bootup.script
sudo ip link add vxlan11 type vxlan id 11 dstport 8472 local 22.22.22.3 nolearning
sudo ip link set up dev vxlan11
sudo brctl addif br11 vxlan11
vtysh -c "conf t" -c "router bgp 65001" -c "neighbor 22.22.22.254 peer-group fabric"
vtysh -c "conf t" -c "router bgp 65001" -c "address-family l2vpn evpn" -c "neighbor fabric activate" -c "advertise-all-vni"
### Show vtysh ###
!
router bgp 65001
bgp router-id 22.22.22.3
no bgp default ipv4-unicast
neighbor fabric peer-group
neighbor fabric remote-as 65001
neighbor fabric capability extended-nexthop
neighbor 22.22.22.254 peer-group fabric
!
address-family l2vpn evpn
neighbor fabric activate
advertise-all-vni
exit-address-family
!

File Metadata

Mime Type
text/plain
Storage Engine
local-disk
Storage Format
Raw Data
Storage Handle
54/28/f27abeb44b99959d02e79ca4affd
Default Alt Text
right-r1 (1 KB)

Event Timeline