Page MenuHomeVyOS Platform

rip PW can't be set at interface config
Closed, ResolvedPublicBUG

Description

vyos@vyos1-lab# set interfaces ethernet eth0 ip rip authentication plaintext-password pw123
[edit]
vyos@vyos1-lab# compare
[edit interfaces ethernet eth0 ip]
+rip {
+ authentication {
+ plaintext-password pw123
+ }
+}
[edit]
vyos@vyos1-lab# commit
[ interfaces ethernet eth0 ip rip authentication plaintext-password pw123 ]
% Configuration failed: validation error.

Please check the logs for more details.

interfaces ethernet eth0 ip rip failed
Commit failed

Logs are empty

Details

Difficulty level
Unknown (require assessment)
Version
1.2.0-rolling+201902020337
Why the issue appeared?
Will be filled on close

Event Timeline

syncer triaged this task as Normal priority.
syncer edited projects, added VyOS 1.3 Equuleus; removed VyOS 1.2 Crux.
zsdc changed the task status from Open to Confirmed.Feb 7 2019, 8:05 PM

Bug confirmed. The problem is in FRRouting CLI (FRRouting 7.1-dev).
Will see what we can do with this.

zsdc reassigned this task from zsdc to Unknown Object (User).Apr 28 2020, 9:36 AM
zsdc added a subscriber: zsdc.
Unknown Object (User) closed this task as Resolved.Apr 28 2020, 7:50 PM

This is solved in both the current LTS and rolling releases.