Page MenuHomeVyOS Platform

Failure to install fpm while building builder docker image
Closed, ResolvedPublicBUG

Description

When trying to build the latest crux builder docker image, tagged vyos/1.2.6, I get the following error:

Step 54/59 : RUN gem install --no-document fpm
 ---> Running in 602ebd7990c1
ERROR:  Error installing fpm:
	ffi requires Ruby version >= 2.3.

Reverting https://github.com/vyos/vyos-build/commit/b32a80c891ca7fe3fbe361a6c7ba5066ac9caff5 "fixes" it for me, but I'm not sure if that's a real fix or not.

Details

Difficulty level
Easy (less than an hour)
Version
1.2.6
Why the issue appeared?
Issues in third-party code
Is it a breaking change?
Perfectly compatible
Issue type
Package upgrade

Event Timeline

This is still an issue.

Any update?

c-po changed the task status from Open to In progress.Sep 13 2022, 7:45 PM
c-po claimed this task.
c-po triaged this task as Normal priority.
c-po changed Difficulty level from Unknown (require assessment) to Easy (less than an hour).
c-po changed Why the issue appeared? from Will be filled on close to Issues in third-party code.
c-po changed Is it a breaking change? from Unspecified (possibly destroys the router) to Perfectly compatible.
c-po set Issue type to Package upgrade.