Page MenuHomeVyOS Platform

Deleting RPKI does not remove entire FRR configuration.
Closed, ResolvedPublic

Description

While movinf RPKI to FRR reload I noticed that I can no longer delete RPKI.

To reproduce:

set protocols rpki cache 192.0.2.1 port 8080
set protocols rpki cache 192.0.2.1 preference 1
commit

delete protocols rpki
commit

vtysh -c "show run" now still reports the RPKI section.

modify_section: starting search for 'rpki' until '\\S+'
_find_first_block: find start='rpki$' stop='\\S+' start_at=0
_find_first_block: no match       0 "!"
_find_first_block: no match       1 "frr version 7.3.1-20210124-00-g293395038"
_find_first_block: no match       2 "frr defaults traditional"
_find_first_block: no match       3 "hostname vyos"
_find_first_block: no match       4 "log syslog"
_find_first_block: no match       5 "log facility local7"
_find_first_block: no match       6 "agentx"
_find_first_block: Found start    7 "rpki"
_find_first_block: no match       8 "  rpki polling_period 600"
_find_first_block: no match       9 "  rpki cache 1.1.1.1 8080 preference 1"
_find_first_block: no match      10 "  exit"
_find_first_block: Found stop    11 "service integrated-vtysh-config"
modify_section:   found match between 7 and 11
modify_section:   remove         7 rpki
modify_section:   remove         8   rpki polling_period 600
modify_section:   remove         9   rpki cache 1.1.1.1 8080 preference 1
modify_section:   remove        10   exit
modify_section:   add            7
_find_first_block: find start='rpki$' stop='\\S+' start_at=8
_find_first_block: no match       8 "service integrated-vtysh-config"
_find_first_block: no match       9 "!"
_find_first_block: no match      10 "line vty"
_find_first_block: no match      11 "!"
_find_first_block: no match      12 "end"
_find_first_block: exit start={repr(start_pattern)} stop={repr(stop_pattern)} start_at={start_at}
modify_section: No more config sections found, exiting
_find_first_element: find start="(ip prefix-list .*|route-map .*|line vty)" start_at=0
_find_first_element: no match     0 "!"
_find_first_element: no match     1 "frr version 7.3.1-20210124-00-g293395038"
_find_first_element: no match     2 "frr defaults traditional"
_find_first_element: no match     3 "hostname vyos"
_find_first_element: no match     4 "log syslog"
_find_first_element: no match     5 "log facility local7"
_find_first_element: no match     6 "agentx"
_find_first_element: no match     7 ""
_find_first_element: no match     8 "service integrated-vtysh-config"
_find_first_element: no match     9 "!"
_find_first_element: Found stop  10 "line vty"
add_before:   add           10
commit_configuration:  Commiting configuration
commit_configuration:  Commiting configuration
commit_configuration:  Commiting configuration
commit_configuration:  Commiting configuration
commit_configuration:  Commiting configuration
commit_configuration:  Commiting configuration
{}




vyos@vyos# vtysh -c "show run"
Building configuration...

Current configuration:
!
frr version 7.3.1-20210124-00-g293395038
frr defaults traditional
hostname vyos
log syslog
log facility local7
agentx
rpki
  rpki polling_period 600
  rpki cache 1.1.1.1 8080 preference 1
  exit
service integrated-vtysh-config
!
interface eth0.201
 ip ospf authentication message-digest
 ip ospf message-digest-key 10 md5 ospfmybllnet
!
router ospf
 ospf router-id 172.18.254.201
 log-adjacency-changes
 auto-cost reference-bandwidth 100
 timers throttle spf 200 1000 10000
 passive-interface default
 no passive-interface eth0.201
 network 172.18.201.0/24 area 0
 network 172.18.254.201/32 area 0
!
line vty
!
end

Details

Difficulty level
Unknown (require assessment)
Version
1.4-rolling
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Unspecified (possibly destroys the router)

Event Timeline

c-po triaged this task as Normal priority.
c-po created this task.
c-po created this object in space S1 VyOS Public.
c-po updated the task description. (Show Details)
c-po changed Version from - to 1.4-rolling.
c-po changed the task status from Open to On hold.Feb 1 2021, 7:56 PM
c-po closed this task as Resolved.