Page MenuHomePhabricator

In the FRR image community-list is not handled correctly
Closed, ResolvedPublicBUG

Description

At reboot community-list entries are not visible in vtysh.
Adding new afterwards seems to work however.
But editing an existing does not work.

The issue seems to be in /opt/vyatta/sbin/vyatta-policy.pl
sub update_community_list

Editing a community-list begins with deleting the old one, so all changes and deletes are handled correctly.
But in FRR this is not possible.

(config)# no ip community-list 7
% Command incomplete: no ip community-list 7

You have to specify the complete line
no ip community-list 7 permit 65001:123

So this i cannot easily try a fix, we need to now the existing rules, or work through the changes.

The manual shows that it should still be possible.
no ip community-list [standard|expanded] NAME
http://docs.frrouting.org/en/latest/bgp.html#miscellaneous-configuration-examples

But the running FRR 5.1-dev in this image only had the following;
(config)# no ip community-list 7

deny    Specify community to reject
permit  Specify community to accept

Details

Difficulty level
Unknown (require assessment)
Version
1.2.0-20180824-frr
Why the issue appeared?
Will be filled on close
Merijn created this task.Aug 25 2018, 7:52 PM
syncer triaged this task as Normal priority.Sep 1 2018, 2:29 PM
syncer assigned this task to dmbaturin.

This is still a problem with vyos 1.2.0-rc2.

dmbaturin closed this task as Resolved.

I've made a workaround for it. I've also reported the root cause to FRR: https://github.com/FRRouting/frr/issues/3215