Page MenuHomeVyOS Platform

accel-ppp: pptp implementation
Closed, ResolvedPublicFEATURE REQUEST

Details

Difficulty level
Normal (likely a few hours)
Version
-
Why the issue appeared?
Will be filled on close

Related Objects

StatusSubtypeAssignedTask
ResolvedFEATURE REQUESThagbard
ResolvedFEATURE REQUESThagbard
ResolvedFEATURE REQUESTDmitry
ResolvedFEATURE REQUESTDmitry
ResolvedFEATURE REQUESTDmitry
ResolvedFEATURE REQUESThagbard

Event Timeline

hagbard triaged this task as Normal priority.Sep 6 2018, 7:17 PM
hagbard created this task.
hagbard changed the task status from Open to In progress.Sep 6 2018, 7:46 PM

Getting close to finishing it.

Sep 17 19:10:15 vyos accel-pptp: pptp: new connection from 10.1.1.102
Sep 17 19:10:15 vyos accel-pptp: :: recv [PPTP Start-Ctrl-Conn-Request <Version 1> <Framing 3> <Bearer 3> <Max-Chan 65535>]
Sep 17 19:10:15 vyos accel-pptp: :: send [PPTP Start-Ctrl-Conn-Reply <Version 1> <Result 1> <Error 0> <Framing 3> <Bearer 3> <Max-Chan 1>]
Sep 17 19:10:16 vyos accel-pptp: :: recv [PPTP Outgoing-Call-Request <Call-ID 0> <Call-Serial 0> <Min-BPS 2400> <Max-BPS 10000000> <Bearer 3> <Framing 3> <Window-Size 3> <Delay 0>]
Sep 17 19:10:16 vyos accel-pptp: :: send [PPTP Outgoing-Call-Reply <Call-ID 1> <Peer-Call-ID 0> <Result 1> <Error 0> <Cause 0> <Speed 10000000> <Window-Size 3> <Delay 0> <Channel 0>]
Sep 17 19:10:16 vyos accel-pptp: :: lcp_layer_init
Sep 17 19:10:16 vyos accel-pptp: :: auth_layer_init
Sep 17 19:10:16 vyos accel-pptp: :: ccp_layer_init
Sep 17 19:10:16 vyos accel-pptp: :: ipcp_layer_init
Sep 17 19:10:16 vyos accel-pptp: :: ipv6cp_layer_init
Sep 17 19:10:16 vyos accel-pptp: :: ppp establishing
Sep 17 19:10:16 vyos accel-pptp: :: lcp_layer_start
Sep 17 19:10:16 vyos accel-pptp: :: lcp_layer_started
Sep 17 19:10:16 vyos accel-pptp: :: auth_layer_start
Sep 17 19:10:16 vyos accel-pptp: ppp0:test123: connect: ppp0 <--> pptp(10.1.1.102)
Sep 17 19:10:16 vyos accel-pptp: ppp0:test123: ppp connected
Sep 17 19:10:16 vyos accel-pptp: ppp0:test123: auth_layer_started
Sep 17 19:10:16 vyos accel-pptp: ppp0:test123: ccp_layer_start
Sep 17 19:10:16 vyos accel-pptp: ppp0:test123: ipcp_layer_start
Sep 17 19:10:16 vyos accel-pptp: ppp0:test123: ipv6cp_layer_start
Sep 17 19:10:16 vyos accel-pptp: ppp0:test123: test123: authentication succeeded
Sep 17 19:10:16 vyos accel-pptp: ppp0:test123: ipcp_layer_started
Sep 17 19:10:16 vyos accel-pptp: ppp0:test123: pptp: ppp started
Sep 17 19:10:16 vyos charon: 09[KNL] 192.168.0.1 appeared on ppp0
Sep 17 19:10:16 vyos charon: 11[KNL] 192.168.0.1 disappeared from ppp0
Sep 17 19:10:16 vyos charon: 13[KNL] 192.168.0.1 appeared on ppp0
Sep 17 19:10:16 vyos charon: 15[KNL] interface ppp0 activated
Sep 17 19:10:16 vyos systemd-sysctl[5284]: Overwriting earlier assignment of net/core/rmem_max in file '/etc/sysctl.d/99-sysctl.conf'.
Sep 17 19:10:18 vyos ntpd[2139]: Listen normally on 8 ppp0 192.168.0.1 UDP 123
Sep 17 19:10:18 vyos ntpd[2139]: peers refreshed
Sep 17 19:11:16 vyos accel-pptp: ppp0:test123: recv [PPTP Echo-Request <Identifier 1000000>]
Sep 17 19:11:16 vyos accel-pptp: ppp0:test123: send [PPTP Echo-Reply <Identifier 1000000>]
Sep 17 19:11:29 vyos charon: 09[KNL] interface ppp0 deactivated
Sep 17 19:11:29 vyos charon: 10[KNL] 192.168.0.1 disappeared from ppp0
Sep 17 19:11:29 vyos charon: 12[KNL] interface ppp0 deleted
Sep 17 19:11:29 vyos accel-pptp: ppp0:test123: recv [PPTP Call-Clear-Request <Call-ID 0>]
Sep 17 19:11:29 vyos accel-pptp: ppp0:test123: terminate
Sep 17 19:11:29 vyos accel-pptp: ppp0:: lcp_layer_free
Sep 17 19:11:29 vyos accel-pptp: ppp0:: auth_layer_free
Sep 17 19:11:29 vyos accel-pptp: ppp0:: ccp_layer_free
Sep 17 19:11:29 vyos accel-pptp: ppp0:: ipcp_layer_free
Sep 17 19:11:29 vyos accel-pptp: ppp0:: ipv6cp_layer_free
Sep 17 19:11:29 vyos accel-pptp: ppp0:: ppp destablished
Sep 17 19:11:29 vyos accel-pptp: ppp0:: send [PPTP Call-Disconnect-Notify <Call-ID 0> <Result 4> <Error 0> <Cause 0>]
Sep 17 19:11:29 vyos accel-pptp: ppp0:: pptp: disconnect by peer
Sep 17 19:11:29 vyos accel-pptp: ppp0:: pptp: disconnect
Sep 17 19:11:29 vyos accel-pptp: ppp0:: disconnected
Sep 17 19:11:30 vyos ntpd[2139]: Deleting interface #8 ppp0, 192.168.0.1#123, interface stats: received=0, sent=0, dropped=0, active_time=72 secs
Sep 17 19:11:30 vyos ntpd[2139]: peers refreshed

hagbard changed the task status from In progress to On hold.Oct 1 2018, 8:33 PM

I asked in the forum if anyone still uses pptp, since windows can now finally ipsec too, I doubt that it is still in use anywhere. I put the pptp implementation on hold and focus on pppoe for the time being.
https://forum.vyos.io/t/pptp-aka-poptop-still-being-used/2518

pasik added a subscriber: pasik.Nov 4 2018, 11:22 AM
hagbard changed the status of subtask T834: accel-ppp: l2tp implementation from Open to In progress.Nov 20 2018, 11:49 PM
hagbard changed the status of subtask T834: accel-ppp: l2tp implementation from In progress to On hold.Dec 6 2018, 7:17 PM
hagbard changed the task status from On hold to Confirmed.Jan 28 2019, 10:57 PM
hagbard changed the task status from Confirmed to In progress.Mar 4 2019, 6:24 PM

All right, ready for the first release. I'll add a few more options for radius tuning which are currently set to static defaults values (like timeouts).

Mar 5 22:46:12 localhost accel-pptp: pptp: new connection from 10.1.1.10
Mar 5 22:46:12 localhost accel-pptp: :: recv [PPTP Start-Ctrl-Conn-Request <Version 1> <Framing 3> <Bearer 3> <Max-Chan 65535>]
Mar 5 22:46:12 localhost accel-pptp: :: send [PPTP Start-Ctrl-Conn-Reply <Version 1> <Result 1> <Error 0> <Framing 3> <Bearer 3> <Max-Chan 1>]
Mar 5 22:46:13 localhost accel-pptp: :: recv [PPTP Outgoing-Call-Request <Call-ID 8475> <Call-Serial 0> <Min-BPS 2400> <Max-BPS 10000000> <Bearer 3> <Framing 3> <Window-Size 3> <Delay 0>]
Mar 5 22:46:13 localhost accel-pptp: :: send [PPTP Outgoing-Call-Reply <Call-ID 12> <Peer-Call-ID 8475> <Result 1> <Error 0> <Cause 0> <Speed 10000000> <Window-Size 3> <Delay 0> <Channel 0>]
Mar 5 22:46:13 localhost accel-pptp: :: send [LCP ConfReq id=96 <auth MSCHAP-v2> <mru 1436> <magic 02ff80d7>]
Mar 5 22:46:13 localhost accel-pptp: :: recv [LCP ConfReq id=1 < 2 6 0 0 0 0 > <magic f63182f9> <pcomp> <accomp>]
Mar 5 22:46:13 localhost accel-pptp: :: send [LCP ConfRej id=1 < 2 6 0 0 0 0 > <pcomp> <accomp>]
Mar 5 22:46:13 localhost accel-pptp: :: recv [LCP ConfAck id=96 <auth MSCHAP-v2> <mru 1436> <magic 02ff80d7>]
Mar 5 22:46:13 localhost accel-pptp: :: recv [LCP ConfReq id=2 <magic f63182f9>]
Mar 5 22:46:13 localhost accel-pptp: :: send [LCP ConfAck id=2 ]
Mar 5 22:46:13 localhost accel-pptp: :: send [MSCHAP-v2 Challenge id=1 <2a8f45e9c6c9e366431951543c73aff2>]
Mar 5 22:46:13 localhost accel-pptp: :: recv [MSCHAP-v2 Response id=1 <4277ae159ba8539dfc9a65b770d63d49>, <f8f44e6599d3db1ab66a63b0234679adede63dd60ee29>, F=0, name="testuser"]
Mar 5 22:46:13 localhost accel-pptp: ppp0:testuser: connect: ppp0 <--> pptp(10.1.1.10)
Mar 5 22:46:13 localhost accel-pptp: ppp0:testuser: send [MSCHAP-v2 Success id=1 "S=1E770632B9383E2EBEF76B1B6371F044E19776CB M=Authentication succeeded"]
Mar 5 22:46:13 localhost accel-pptp: ppp0:testuser: testuser: authentication succeeded
Mar 5 22:46:13 localhost netplugd[1025]: ppp0: ignoring event
Mar 5 22:46:13 localhost netplugd[1025]: ppp0: ignoring event
Mar 5 22:46:13 localhost accel-pptp: ppp0:testuser: recv [IPCP ConfReq id=1 < 2 6 0 2d f 1 > <addr 0.0.0.0>]
Mar 5 22:46:13 localhost accel-pptp: ppp0:testuser: send [IPCP ConfReq id=32 <addr 10.200.200.1>]
Mar 5 22:46:13 localhost accel-pptp: ppp0:testuser: send [IPCP ConfRej id=1 < 2 6 0 2d f 1 >]
Mar 5 22:46:13 localhost accel-pptp: ppp0:testuser: recv [IPCP ConfAck id=32 <addr 10.200.200.1>]
Mar 5 22:46:13 localhost accel-pptp: ppp0:testuser: recv [IPCP ConfReq id=2 <addr 0.0.0.0>]
Mar 5 22:46:13 localhost accel-pptp: ppp0:testuser: send [IPCP ConfNak id=2 <addr 192.168.0.10>]
Mar 5 22:46:13 localhost accel-pptp: ppp0:testuser: recv [IPCP ConfReq id=3 <addr 192.168.0.10>]
Mar 5 22:46:13 localhost accel-pptp: ppp0:testuser: send [IPCP ConfAck id=3]
Mar 5 22:46:13 localhost netplugd[1025]: ppp0: ignoring event

found in the old documentation that mppe is always set to the highest, will implement it as a config option with the default of mppe require.

hagbard changed Difficulty level from Unknown (require assessment) to Normal (likely a few hours).Mar 6 2019, 9:12 PM

I didn't find any issues so far, aside from the fact that I think no one is using pptp anymore, I'll keep this task still open for a few days just to make sure the replacement was successful.

hagbard changed the status of subtask T1284: accel-ppp: pptp implementation documention from Open to In progress.Mar 6 2019, 11:26 PM
hagbard closed this task as Resolved.Mar 12 2019, 8:20 PM
hagbard changed the status of subtask T834: accel-ppp: l2tp implementation from On hold to In progress.Apr 15 2019, 5:37 PM
c-po moved this task from Need Triage to Finished on the VyOS 1.3 Equuleus board.May 26 2019, 3:45 PM
hagbard changed the status of subtask T834: accel-ppp: l2tp implementation from In progress to On hold.Jul 8 2019, 10:40 PM
hagbard changed the status of subtask T834: accel-ppp: l2tp implementation from On hold to In progress.Jul 15 2019, 3:06 PM
hagbard changed the status of subtask T834: accel-ppp: l2tp implementation from In progress to Needs testing.Jul 25 2019, 5:20 PM